CodeForces 626B

CodeForces 626B 

Description

Catherine has a deck of n cards, each of which is either red, green, or blue. As long as there are at least two cards left, she can do one of two actions:

  • take any two (not necessarily adjacent) cards with different colors and exchange them for a new card of the third color;
  • take any two (not necessarily adjacent) cards with the same color and exchange them for a new card with that color.

She repeats this process until there is only one card left. What are the possible colors for the final card?

Input

The first line of the input contains a single integer n (1 ≤ n ≤ 200) — the total number of cards.

The next line contains a string s of length n — the colors of the cards. s contains only the characters 'B', 'G', and 'R', representing blue, green, and red, respectively.

Output

Print a single string of up to three characters — the possible colors of the final card (using the same symbols as the input) in alphabetical order.

Sample Input

Input
2
RB
Output
G
Input
3
GRG
Output
BR
Input
5
BBBBB
Output
B

Sample Output

Hint

In the first sample, Catherine has one red card and one blue card, which she must exchange for a green card.

In the second sample, Catherine has two green cards and one red card. She has two options: she can exchange the two green cards for a green card, then exchange the new green card and the red card for a blue card. Alternatively, she can exchange a green and a red card for a blue card, then exchange the blue card and remaining green card for a red card.

In the third sample, Catherine only has blue cards, so she can only exchange them for more blue cards.

分析:

第一种情况:

B  G   R

0   0    _  (输出R)  (类似输出G、B)

第二种情况:

B  G   R

1   1    0  (输出R)  (类似输出G、B)

第三种情况:

B     G     R

1     >1    0  (输出BR)  (类似输出BG、BR、GR)

(G自身变,直到最后变为1后,再与B一起变,就可以变R,最后就剩R)(或者变到G为2时,G与B变R,R再与G一起变B,最后就剩B)


其余情况输出;BGR(都可以利用上面的变法,最后得到BGR)

My  solution:

/*2016.3.6*/

#include<stdio.h>
#include<string.h>
int a[4];
int main()
{
	int i,n,m;
	char h;
	while(scanf("%d",&n)==1)
	{
		memset(a,0,sizeof(a));
		getchar();
		for(i=1;i<=n;i++)
		{
			//getchar();
			scanf("%c",&h);
			if(h=='B')
			a[1]++;
			else if(h=='G')
			a[2]++;
			else
			a[3]++;
		}
		
		if(a[1]==0&&a[2]==0)
		printf("R\n");
		else
		{
			if(a[1]==0&&a[3]==0)
			printf("G\n");
			else
			{
				if(a[2]==0&&a[3]==0)
				printf("B\n");
				else 
				if(a[1]==0&&a[2]==1)
				{
					if(a[3]==1)
					printf("B\n");
					else
					printf("BG\n");
				}
				else
				{
					if(a[1]==0&&a[3]==1)
					{
						if(a[2]==1)
						printf("B\n");
						else
						printf("BR\n");
					}
					else
					if(a[2]==0&&a[1]==1)
					{
						if(a[3]==1)
						printf("G\n");
						else
						printf("BG\n");
					}
					else
					if(a[2]==0&&a[3]==1)
					{
						if(a[1]==1)
						printf("G\n");
						else
						printf("GR\n");
					}
					else
					if(a[3]==0&&a[1]==1)
					{
						if(a[2]==1)
						printf("R\n");
						else
						printf("BR\n");
					}
					else
					if(a[3]==0&&a[2]==1)
					{
						if(a[1]==1)
						printf("R\n");
						else
						printf("GR\n");
					}
					else
					printf("BGR\n");
				}
			}
		}	
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值