Tricky Sum(等比数列)

19 篇文章 0 订阅
15 篇文章 0 订阅

Tricky Sum
Crawling in process... Crawling failed Time Limit:1000MS    Memory Limit:262144KB     64bit IO Format:%I64d & %I64u

Description

In this problem you are to calculate the sum of all integers from 1 to n, but you should take all powers of two with minus in the sum.

For example, for n = 4 the sum is equal to - 1 - 2 + 3 - 4 =  - 4, because 1, 2 and 4 are20, 21 and 22 respectively.

Calculate the answer for t values of n.

Input

The first line of the input contains a single integer t (1 ≤ t ≤ 100) — the number of values ofn to be processed.

Each of next t lines contains a single integern (1 ≤ n ≤ 109).

Output

Print the requested sum for each of t integersn given in the input.

Sample Input

Input
2
4
1000000000
Output
-4
499999998352516354

Sample Output

     
     
302000
 

Hint

The answer for the first sample is explained in the statement.

求前n个数的和,1-------n;(其中等于2^m(m=0、1、2、。。。。。)都为负数,其余数都为负数。

2的所有次方和:s=2^(t+1)-1(等比数列求和且2^t<n)

    h=1+2+3+4+……+n=n(n+1)/2

最后结果:

ans=h-2*t;

My  solution:

/*2016.3.12*/

<pre name="code" class="cpp">#include<stdio.h>
long long n;
long long ans,su;
void  jie()
{
	int i,t1=0;
	long long time=2;
	ans=1;
	while(ans<=n)
	{
		t1++;
		ans*=2;
	}
	i=t1;
	ans=1;
	while(i)
	{
		if(i%2)
		ans*=time;
		i/=2;
		time*=time;
	}
	return ;
}
int main()
{
	long long i;
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%I64d",&n);
		jie();
		if(n%2==0)
		su=(n/2)*(n+1);
		else
		su=((n+1)/2)*n;
		su=su-2*(ans-1);
		printf("%I64d\n",su);
	}
	
	return 0;
}



                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值