Monkey and Banana 【HDU】-1069

点击打开链接

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15952    Accepted Submission(s): 8463


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
  
  
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
  
  
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 

Source
 

中文版: 点击打开链接

计算猴子们最高可以堆出的砖块们的最大高度

代码:

#include <cstdio>
#include <cstring>
#include <map>
#include <algorithm>
#include <vector>
using namespace std;
#define INF 0x7fffffff 
struct Brick
{
	int x,y,z;
}brick[200];
int ant;
void UpDate(int x,int y,int z)   //每个砖块的3条边可以组成6种不同的长宽高
{
	brick[ant].x=x;
	brick[ant].y=y;
	brick[ant++].z=z;
	
	brick[ant].x=x;
	brick[ant].y=z;
	brick[ant++].z=y;
	
	brick[ant].x=y;
	brick[ant].y=x;
	brick[ant++].z=z;
	
	brick[ant].x=y;
	brick[ant].y=z;
	brick[ant++].z=x;
	
	brick[ant].x=z;
	brick[ant].y=x;
	brick[ant++].z=y;
	
	brick[ant].x=z;
	brick[ant].y=y;
	brick[ant++].z=x;
}
bool cmp(Brick a,Brick b)   //长或宽必须是逐渐减小 
{
	if(a.x==b.x)
	return a.y>b.y;
	return a.x>b.x; 
}
int main()
{
	int n,Case=1;
	while(scanf("%d",&n)!=EOF&&n)
	{
		ant=1;
		for(int i=1;i<=n;i++)
		{
			int x,y,z;
			scanf("%d%d%d",&x,&y,&z);
			UpDate(x,y,z);
		}
		ant--;
		sort(brick+1,brick+ant+1,cmp);
		
		int dp[200],ans=0;
		for(int i=1;i<=ant;i++)
		{
			dp[i]=brick[i].z;   //第一块砖的高度 
			for(int j=1;j<i;j++)
			{
				if(brick[i].x < brick[j].x && brick[i].y < brick[j].y)  //满足题意下面的砖头比在它上面的砖头小 
				dp[i]=max(dp[i],dp[j]+brick[i].z);  // dp[j]表示dp[j:(1~i-1)]以第i-1块砖的高度和 
				ans=max(ans , dp[i]);    
				
			}
		}
		printf("Case %d: maximum height = %d\n",Case++,ans);
	}
	return 0;
}
//dp[i]:  i表示以第i块砖头结尾能到达的最高高度 
//dp[i] = max(brick[i].z , dp[j:(1~i-1)] + brick[i].z)
//if : brick[i].x < brick[j].x && brick[i].y < brick[j].y


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值