Monkey and Banana HDU - 1069 (贪心+dp)

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food. 

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks. 

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n, 
representing the number of different blocks in the following data set. The maximum value for n is 30. 
Each of the next n lines contains three integers representing the values xi, yi and zi. 
Input is terminated by a value of zero (0) for n. 

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height". 

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题意:给你n种立方体,每种立方体有无限多个,求出最高能达到的高度(只要下面的立方体比上面的大,那么就可以堆积上去)

题解:设长宽高分别为x,y,z。那么每种立方体可能提供的高度有3种,分别是x,y,z。所以每种立方体我们只需要保留3个即可,接着我们按x,y进行排序,最底下的当然是x和y最大的。接着按高度求最长上升子序列就行

坑点:同时按x,y来排序可能会出现x特别大,y特别小的情况,所以为了避免这种情况,在建立立方体之前,我们尽量把x,y,z中大的作为长。

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <map>
#include <vector>
#include <set>
#include <string>
#include <math.h>
#include <stack>
using namespace std;
typedef long long ll;
const int maxn = 5e3+100;
#define inf 0x3f3f3f3f
int n;
int dp[maxn];
struct Point
{
    int x,y,z;
}p[maxn];
void add(int x,int y,int z,int i)
{
    p[i].x=x;
    p[i].y=y;
    p[i].z=z;
}
bool cmp(Point a,Point b)
{
    if(a.x==b.x) return a.y>b.y;
    return a.x>b.x;
}
int main()
{
    #ifndef ONLINE_JUDGE
        freopen("in.txt","r",stdin);
        freopen("out.txt","w",stdout);
    #endif
    int Case=0;
    while(scanf("%d",&n)!=EOF&&n)
    {
        for(int i=0;i<n;i++)
        {
            int x,y,z;
            scanf("%d%d%d",&x,&y,&z);
            add(max(x,z),min(x,z),y,3*i);//一定要取最大和最小
            add(max(x,y),min(x,y),z,3*i+1);
            add(max(z,y),min(z,y),x,3*i+2);
        }
        sort(p,p+3*n,cmp);
        memset(dp,0,sizeof(dp));
        dp[0]=p[0].z;
        int ans=0;
        for(int i=1;i<3*n;i++)
        {
            int M=0;
            for(int j=0;j<i;j++)
            {
                if(p[i].x<p[j].x&&p[i].y<p[j].y&&dp[j]>M)
                {
                    M=dp[j];
                }
            }
            dp[i]=max(dp[i],M+p[i].z);
            ans=max(dp[i],ans);
        }
        printf("Case %d: maximum height = %d\n",++Case,ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值