HDU-1069 Monkey and Banana

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17886    Accepted Submission(s): 9566


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
 
 
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
 
 
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342

题意:给你一堆砖块的长宽高,要你用这些将这些砖块叠起来,叠的要求是上面的砖块必须严格小于下面的砖块。每种砖块数量无限。要你求能叠起来的最高的高度。

解法:最长上升子序列的二维版本。题中虽然给定砖块的数量无限,但实际能用到的只有三种,因为同样大小的砖块不可能使用第二次。这样,问题就转换成为了一个LIS问题。先将砖块按长、宽分别作为第一第二关键词排序。再按LIS的dp方法进行dp即可。

(如果按宽排序,则按长dp)

#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e4;
typedef long long ll;
bool isprime[maxn];
typedef struct Point{
    int x,y,z;
    Point(int xx,int yy,int zz){
        x=xx;y=yy;z=zz;
    }
    Point(){}
}point;
point a[maxn];
int dp[maxn];
int cmp(const void* a, const void *b){
    point *pa = (point*)a, *pb =(point*)b;
    if(pa->x!=pb->x) return pa->x-pb->x;
    return pa->y-pb->y;
}
int main()
{
    int n;
    int cnt = 1;
    while(cin>>n&&n){
        int x,y,z,j=0;
        for(int i = 0; i < n; i++)
        {
            cin>>x>>y>>z;
            a[j++] = point(x,y,z);
            a[j++] = point(x,z,y);
            a[j++] = point(y,x,z);
            a[j++] = point(y,z,x);
            a[j++] = point(z,x,y);
            a[j++] = point(z,y,x);//将三种姿势的砖块加入
        }
        qsort(a,6*n,sizeof(point),cmp);
        for(int i = 0; i < 6*n; i++)
        {
            dp[i] = a[i].z;
            //cout<<a[i].x<<' '<<a[i].y<<' '<<a[i].z<<endl;
        }
        for(int i = 1; i < 6*n; i++)
            for(int j = 0; j < i; j++){
                if(a[j].y < a[i].y && a[j].x < a[i].x)//虽然长度已排序但仍存在长度相等的需要排除
                    dp[i] = max(dp[i],dp[j] + a[i].z);
            }
        printf("Case %d: maximum height = ",cnt++);
        cout<<*max_element(dp, dp+6*n)<<endl;//找出最大值即可
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值