3295 Tautology

Tautology
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3462 Accepted: 1294

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

 

A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not

Source

 

 

开始的时候很没头绪,后来看了一些解题报告,略懂。

因为每个表达式都要符合他自己的规则的,所以从前往后就可以了,就是不会出现一些AXAXAXAX这种

采用的还是递归的形式,递归的确很强大

还有就是位运算吗,因为只有5个变量,并且只有可能0,1取值

所以用5个位去变换他即可

 

#include<iostream>

#include<string>

#include<cctype>

using namespace std;

int  val;

string s;

int eval(int &x)

{

    char ch=s[x++];

    if(islower(ch))  return (val>>(ch-'p'))&1;//5位上的数表示相应的+,—

    if(ch=='N')  return !eval(x);

    int v1=eval(x) ,v2=eval(x);

    if(ch=='K') return v1&v2;

    if(ch=='A') return v1|v2;

    if(ch=='C') return !v1|v2;

    if(ch=='E') return v1==v2;

}

int main()

{

    int x;

    while(cin>>s&&s!="0")

    {

       for(val=0;val<32;val++)

        if(!eval(x=0)) break;

       if(val<32)  cout<<"not/n";

       else  cout<<"tautology/n";

    }

    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值