POJ 3295-Tautology(模拟-逻辑表达式)

Tautology
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12534 Accepted: 4776

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not

Source


题目意思:

p,q,r,s,t是变量,取值是0或1;
K,A,N,C,E是逻辑运算符,运算规则分别是:
————————————
K and x&&y
A or x||y
N not !x
C implies (!x)||y
E equals x==y
————————————
给定一个表达式,计算其是否恒为真,如果是,输出“tautology”,否则输出“not”。

解题思路:

由于这些逻辑运算符都是满足左结合性的,所以读取表达式后,需要从后向前依次进行计算。
而且5个变量一共有2^5=32种情况,所以可使用5重循环来模拟各个情况,分别代入计算判断即可。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;

int K(int x,int y)//K and x&&y
{
    return x&&y;
}
int A(int x,int y)//A or x||y
{
    return x||y;
}
int N(int x)//N not !x
{
    return !x;
}
int C(int x,int y)//C implies (!x)||y
{
    return A(N(x),y);
}
int E(int x,int y)//E equals x==y
{
    return x==y;
}

string str;
int c[110];
int p,q,r,s,t;
int x,y;
bool solve()
{
    memset(c,'\0',sizeof(c));
    int j=0;
    for(int i=str.size(); i>=0; --i)
    {
        switch(str[i])
        {
        case 'p':
            c[j++]=p;
            break;
        case 'q':
            c[j++]=q;
            break;
        case 'r':
            c[j++]=r;
            break;
        case 's':
            c[j++]=s;
            break;
        case 't':
            c[j++]=t;
            break;

        case 'K':
            x=c[--j];
            y=c[--j];
            c[j++]=K(x,y);
            break;
        case 'A':
            x=c[--j];
            y=c[--j];
            c[j++]=A(x,y);
            break;
        case 'N':
            x=c[--j];
            c[j++]=N(x);
            break;
        case 'C':
            x=c[--j];
            y=c[--j];
            c[j++]=C(x,y);
            break;
        case 'E':
            x=c[--j];
            y=c[--j];
            c[j++]=E(x,y);
            break;
        }
    }
    if(c[0]==0) return false;
    else return true;
}

int main()
{
    while(cin>>str&&str!="0")
    {
        bool flag=true;
        for(p=0; p<2; p++)
            for(q=0; q<2; q++)
                for(r=0; r<2; r++)
                    for(s=0; s<2; s++)
                        for(t=0; t<2; t++)
                        {
                            if(!solve())
                            {
                                flag=false;
                                break;
                            }
                        }
        if(flag) puts("tautology");
        else puts("not");
    }
    return 0;
}
/*
ApNp
ApNq
0
*/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值