3169 Layout 差分约束系统

 

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2066 Accepted: 993

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

Source

可以说是比较简单的差分约束系统了。
很明显的两个
第一个要求是b-a<=c,这个很明显,构图只要是A-->B,且权值为C即可
另一个要求是B-A>=C,反一下就变成了A-B<=-C,那么构图一、只要B-->A且权值为-C即可
SO EASY!
杀啊,SPFA!
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
#define swap(t,a,b) (t=a,a=b,b=t)
const int E=20002;
const int V=1001;
const int INF=1<<25-1;
struct EDGE
{
    int link,val,next;
}edge[E];
int head[V],cnt[V],dist[V],e;
bool vis[V];
void addedge(int a,int b,int c)
{
    edge[e].link=b;
    edge[e].val=c;
    edge[e].next=head[a];
    head[a]=e++;
}
int relax(int u,int v,int c)
{
    if(dist[v]>dist[u]+c)//求的是最大值,若求最小值,反号
    {
        dist[v]=dist[u]+c;
        return 1;
    }
    return 0;
}
int SPFA(int src,int n)
{
    memset(vis,false,sizeof(vis));
    memset(cnt,0,sizeof(cnt));
    for(int i=1;i<=n;++i)  dist[i]=INF;
    dist[src]=0;
    vis[src]=true;
    queue<int> q;
    q.push(src);
    ++cnt[src];
    while(!q.empty())
    {
        int u,v;
        u=q.front();
        q.pop();
        vis[u]=false;
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            v=edge[i].link;
            if(relax(u,v,edge[i].val)==1&&!vis[v])
            {
                q.push(v);
                vis[v]=true;
                if((++cnt[v])>n) return -1;
            }
        }
    }
    if(dist[n]==INF) return -2; // src与n不可达,有些题目可省!!!
    return dist[n]; // 返回src到n的最短距离,根据题意不同而改变
}
int main()
{
    int n,ml,md,a,b,c,t;
    while(scanf("%d%d%d",&n,&ml,&md)!=EOF)
    {
        e=0;
        memset(head,-1,sizeof(head));
        for(int i=1;i<=ml;++i)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(a>b) swap(t,a,b);
            addedge(a,b,c);
        }
        for(int i=1;i<=md;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(a<b) swap(t,a,b);
            addedge(a,b,-c);
        }
        printf("%d/n",SPFA(1,n));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值