2536 Gopher II

Gopher II
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 3494 Accepted: 1461

Description

The gopher family, having averted the canine threat, must face a new predator. 

The are n gophers and m gopher holes, each at distinct (x, y) coordinates. A hawk arrives and if a gopher does not reach a hole in s seconds it is vulnerable to being eaten. A hole can save at most one gopher. All the gophers run at the same velocity v. The gopher family needs an escape strategy that minimizes the number of vulnerable gophers.

Input

The input contains several cases. The first line of each case contains four positive integers less than 100: n, m, s, and v. The next n lines give the coordinates of the gophers; the following m lines give the coordinates of the gopher holes. All distances are in metres; all times are in seconds; all velocities are in metres per second.

Output

Output consists of a single line for each case, giving the number of vulnerable gophers.

Sample Input

2 2 5 10
1.0 1.0
2.0 2.0
100.0 100.0
20.0 20.0

Sample Output

1

Source

 

 

 

 

 

 

#include<stdio.h>

#include<string.h>

int usedif[100];

//usedif[i]记录Y顶点子集中编号为i的顶点是否使用,注意Y子集中的最多顶点数为(7-1)*12+12=84

int link[100];//link[i]记录与Y顶点子集中编号为i的顶点相连的X顶点子集中x的编号

int mat[305][100];//mat[i][j]表示顶点i与j之间是否有边

int gx,gy;//gx为X顶点子集中的顶点数目,gy为Y顶点子集中的顶点数目

double go[100][2],ve[100][2];

bool can(int t) //判断X中的顶点t在Y中是否有顶点与之匹配

{

    for(int i=0; i<gy; i++)

    {

        if(usedif[i]==0&&mat[t][i]) //Y中的顶点i未匹配且t与i之间有边

        {

            usedif[i]=1;

            if(link[i]==-1||can(link[i])) //link[i]=-1表示顶点i还未匹配

            {

                link[i]=t;

                return true;

            }

        }

    }

    return false;

}

int MaxMatch()

{

    int num=0;

    memset(link,-1,sizeof(link));

    for(int i=0; i<gx; i++) //对X中的每个顶点在Y中寻找与其匹配的顶点

    {

        memset(usedif,0,sizeof(usedif));

        if(can(i))  num++;

    }

    return num;//返回最大匹配数

}

int main()

{

    int n,m,s,v;

    while(scanf("%d%d%d%d",&n,&m,&s,&v)!=EOF)

    {

        gx=n;

        gy=m;

        memset(mat,0,sizeof(mat));

        for(int i=0;i<n;i++)  scanf("%lf%lf",&go[i][0],&go[i][1]);

        for(int i=0;i<m;i++) scanf("%lf%lf",&ve[i][0],&ve[i][1]);

        int d=s*v*s*v;

        for(int i=0;i<n;i++)

          for(int j=0;j<m;j++)

             if((go[i][0]-ve[j][0])*(go[i][0]-ve[j][0])+(go[i][1]-ve[j][1])*(go[i][1]-ve[j][1])<=d)  mat[i][j]=1;

        printf("%d/n",n-MaxMatch());

    }

    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值