Optimal ArrayMultiplication Sequence


Optimal ArrayMultiplication Sequence

Given two arrays A and B, we can determinethe array C = A B using the standard definition of matrix multiplication:

The number of columns in the A array mustbe the same as the number of rows in the B array. Notationally, let's say thatrows(A) and columns(A) are the number of rows and columns, respectively, in theA array. The number of individual multiplications required to compute theentire C array (which will have the same number of rows as A and the samenumber of columns as B) is then rows(A) columns(B) columns(A). For example, ifA is a 10 x 20 array, and B is a 20 x 15 array, it will take 10 x 15 x 20, or3000 multiplications to compute the C array.


To perform multiplication of more than two arrays we have a choice of how toproceed. For example, if X, Y, and Z are arrays, then to compute X Y Z we couldeither compute (X Y) Z or X (Y Z). Suppose X is a 5 x 10 array, Y is a 10 x 20array, and Z is a 20 x 35 array. Let's look at the number of multiplicationsrequired to compute the product using the two different sequences:

(X Y) Z


5 x 20 x 10 = 1000 multiplications to determine the product (X Y), a 5 x 20array.

Then 5 x 35 x 20 = 3500 multiplications to determine the final result.

Total multiplications: 4500.

X (Y Z)

10 x 35 x 20 = 7000 multiplications todetermine the product (Y Z), a 10 x 35 array.

Then 5 x 35 x 10 = 1750 multiplications to determine the final result.

Total multiplications: 8750. 

Clearly we'll be able to compute (X Y) Z using fewer individual multiplications.

Given the size of each array in a sequenceof arrays to be multiplied, you are to determine an optimal computationalsequence. Optimality, for this problem, is relative to the number of individualmultiplcations required.


Input

For each array in the multiple sequences of arrays to be multiplied you will begiven only the dimensions of the array. Each sequence will consist of aninteger N which indicates the number of arrays to be multiplied, and then Npairs of integers, each pair giving the number of rows and columns in an array;the order in which the dimensions are given is the same as the order in whichthe arrays are to be multiplied. A value of zero for N indicates the end of theinput. N will be no larger than 10.


Output

Assume the arrays are named A1, A2, ..., AN. Your output for each input case isto be a line containing a parenthesized expression clearly indicating the orderin which the arrays are to be multiplied. Prefix the output for each case withthe case number (they are sequentially numbered, starting with 1). Your outputshould strongly resemble that shown in the samples shown below. If, by chance,there are multiple correct sequences, any of these will be accepted as a validanswer.


Sample Input

3
1 5
5 20
20 1
3
5 10
10 20
20 35
6
30 35
35 15
15 5
5 10
10 20
20 25
0


Sample Output

Case 1: (A1 x (A2 x A3))
Case 2: ((A1 x A2) x A3)
Case 3: ((A1 x (A2 x A3)) x ((A4 x A5) x A6))

 

题目解读:

本题是典型的动态规划应用问题。是矩阵连乘问题的扩展,自然可以套用矩阵连乘的动态规划转移方程。

下面是源代码:

注意Case 1:和括号之间有个空格

#include<iostream>

usingnamespace std;

 

#definemaxn 13 //输入n的最大值

 

 

intp[maxn+1];//存放着数组的维数,p0p1是滴一个数组的行列,其余以此类推

intvalue[maxn+1][maxn+1];//value[i][j]表示矩阵Ai乘到矩阵Aj的最小值

intkey[maxn+1][maxn+1];//key[i][j]表示矩阵i到j的划分

intn;//输入矩阵的数目

voiddp();

voidkuohao(int i,int j);

intmain()

{

    int casenum=1;

    cin>>n;

    while(n!=0)

    {

        for(int i=0;i<n;i++)

        {

            int j;

            if(i==0)

            {

                cin>>p[0];

                cin>>p[1];

            }

            else

            {

                cin>>j;

                cin>>p[i+1];

            }

        }

        cout<<"Case"<<casenum<<": ";

        casenum+=1;

        dp();

        cin>>n;

    }

    return 0;

}

voiddp()

{

    for(int i=0;i<=n;i++)

    {

        for(int j=0;j<=n;j++)

        {

            value[i][j]=0;

            key[i][j]=-1;

        }

    }

    for(int i=n-1;i>0;i--)

    {

        for(int j=i+1;j<=n;j++)

        {

            int min=-1;

            int s;

            for(int k=i;k<j;k++)

            {

                if(min<0)

                {

                    min=value[i][k]+value[k+1][j]+p[i-1]*p[k]*p[j];

                    s=k;

                }

                if(min>value[i][k]+value[k+1][j]+p[i-1]*p[k]*p[j])

                {

                    min=value[i][k]+value[k+1][j]+p[i-1]*p[k]*p[j];

                    s=k;

                }

            }

            value[i][j]=min;

            key[i][j]=s;

        }

    }

    cout<<"(";

    kuohao(1,n);

    cout<<")"<<endl;

}

voidkuohao(int i,int j)

{

    if(i==j)

        cout<<"A"<<i;

    else if(i==(j-1))

        cout<<"A"<<i<<"x A"<<j;

    else

    {

        if(i!=key[i][j])

            cout << "(";

        kuohao(i,key[i][j]);

        if (i!=key[i][j])

            cout<<") x ";

        else

            cout<<" x ";

        if (key[i][j]+1!=j)

            cout<<"(";

        kuohao(key[i][j]+1,j);

        if (key[i][j]+1!=j)

            cout << ")";

    }

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值