回溯法Perfect Cubes

Perfect Cubes

Description

For hundreds ofyears Fermat's Last Theorem, which stated simply that for n > 2 there existno integers a, b, c > 1 such that a^n = b^n + c^n, has remained elusivelyunproven. (A recent proof is believed to be correct, though it is stillundergoing scrutiny.) It is possible, however, to find integers greater than 1that satisfy the "perfect cube" equation a^3 = b^3 + c^3 + d^3 (e.g.a quick calculation will show that the equation 12^3 = 6^3 + 8^3 + 10^3 isindeed true). This problem requires that you write a program to find all setsof numbers {a,b,c,d} which satisfy this equation for a <= N.

Input

One integer N (N<= 100).

Output

The output shouldbe listed as shown below, one perfect cube per line, in non-decreasing order ofa (i.e. the lines should be sorted by their a values). The values of b, c, andd should also be listed in non-decreasing order on the line itself. There doexist several values of a which can be produced from multiple distinct sets ofb, c, and d triples. In these cases, the triples with the smaller b valuesshould be listed first.

Sample Input

24

Sample Output

Cube = 6, Triple = (3,4,5)

Cube = 12, Triple = (6,8,10)

Cube = 18, Triple = (2,12,16)

Cube = 18, Triple = (9,12,15)

Cube = 19, Triple = (3,10,18)

Cube = 20, Triple = (7,14,17)

Cube = 24, Triple = (12,16,20)

 

本题很简单,代码如下:

 

#include<iostream>

 

using namespacestd;

 

#define maxN 200

#define maxNN 205

#define maxM 5

 

intvisited[maxNN];

intselected[maxNN];

int ans[maxM];

 

void DFS(int n,intindex);

int main()

{

       int n;

       cin>>n;

       for(int i=6;i<=n;i++)

       {

              for(int j=0;j<=n;j++)

              {

                     visited[j]=0;

                     selected[j]=0;

              }

              DFS(i,0);

       }

       return 0;

}

void DFS(int n,intindex)

{

       if(index==3)

       {

       if((n*n*n==ans[0]*ans[0]*ans[0]+ans[1]*ans[1]*ans[1]+ans[2]*ans[2]*ans[2])&&(selected[ans[0]]*selected[ans[1]]*selected[ans[2]]==0))

              {

                     cout<<"Cube ="<<n<<", Triple =("<<ans[0]<<","<<ans[1]<<","<<ans[2]<<")"<<endl;

                     selected[ans[0]]=selected[ans[1]]=selected[ans[2]]=1;

              }

              return ;

       }

       for(int i=2;i<n;i++)

       {

              if(!visited[i])

              {

                     visited[i]=1;

                     ans[index]=i;

                     DFS(n,index+1);

                     visited[i]=0;

              }

       }

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值