HDU 1711 Number Sequence

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11494    Accepted Submission(s): 5245


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
  
6 -1
 

Source
 
解题思路:KMP模板题
#include<iostream>
#include<cstdio>
using namespace std;
int a[1000005],b[10005];
void get_next(int *T,int *next,int len)
{
    int j=0,k=-1;
    next[0]=-1;
    while(j!=len)
    {
        if(k==-1||T[j]==T[k])
        {
            j++;k++;
            if(T[j]!=T[k])
                next[j]=k;
            else
                next[j]=next[k]; 
        }
        else
            k=next[k];
    }
}
int kmp(int *A,int *B,int len,int len2)
{
    int *next=new int[len+1];
    get_next(B,next,len);
    int index=0,i=0,j=0;
    while(i!=len2&&j!=len)
    {
        if(A[i]==B[j])
            i++,j++;
        else
        {
            index+=j-next[j];
            if(next[j]!=-1)
                j=next[j];
            else
            {
                j=0;
                i++;
            }
        }
    }
    delete next;
    if(j==len)
        return index+1;
    else
        return -1;
}
int main()
{
    int t,m,n,i;
    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        scanf("%d%d",&n,&m);
        for(i=0;i<n;i++)
            scanf("%d",a+i);
        for(i=0;i<m;i++)
            scanf("%d",b+i);
        printf("%d\n",kmp(a,b,m,n));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值