POJ 1065 Wooden Sticks

Wooden Sticks
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 15102 Accepted: 6210

Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1 

Sample Output

2
1
3

Source

Taejon 2001

这道题实质是求升序序列的最大个数,我用的是贪心+快排,代码如下。遗憾的是我证明不了为什么要用贪心,orz= =!有哪位看到此博文的大牛教教我呗。

#include<iostream>
#include<cmath>
using namespace std;
struct stick
{
  int l,w;
  bool visit;
}s[10000];
int cmp(const void *a,const void *b)//先按木棍的长度从小到大排序,长度相同再排重量
{
	struct stick *aa=(stick *)a;
    struct stick *bb=(stick *)b;
	if(aa->l!=bb->l)
		return(aa->l>bb->l?1:-1);
	else
	    return(aa->w-bb->w);
}
int main()
{int m,n,i,j,k,t,temp;
cin>>n;
while(n--)
{t=0;
cin>>m;
for(i=0;i<m;i++)
	{
		cin>>s[i].l>>s[i].w;
		s[i].visit=false;
    }
qsort(s,m,sizeof(s[0]),cmp);
for(j=0;j<m;j++)
{if(!s[j].visit)
{       s[j].visit=true;
        temp=s[j].w;
for(k=j+1;k<m;k++)
	  {if(s[k].w>=temp&&!s[k].visit)//如果后一根满足条件且未使用,将其加入此序列
			{
				s[k].visit=true;
				temp=s[k].w;
            }
       }
    t++;//统计序列个数
    }
}
cout<<t<<endl;
}
return 0;
}


 BTW:今年长春网赛的Alice and Bob貌似就是这道题的翻版。不过我今年居然把报名时间错过了。尴尬

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值