HDU 4472 Count

Count

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 36    Accepted Submission(s): 18


Problem Description
Prof. Tigris is the head of an archaeological team who is currently in charge of an excavation in a site of ancient relics.
This site contains relics of a village where civilization once flourished. One night, examining a writing record, you find some text meaningful to you. It reads as follows.
“Our village is of glory and harmony. Our relationships are constructed in such a way that everyone except the village headman has exactly one direct boss and nobody will be the boss of himself, the boss of boss of himself, etc. Everyone expect the headman is considered as his boss’s subordinate. We call it relationship configuration. The village headman is at level 0, his subordinates are at level 1, and his subordinates’ subordinates are at level 2, etc. Our relationship configuration is harmonious because all people at same level have the same number of subordinates. Therefore our relationship is …”
The record ends here. Prof. Tigris now wonder how many different harmonious relationship configurations can exist. He only cares about the holistic shape of configuration, so two configurations are considered identical if and only if there’s a bijection of n people that transforms one configuration into another one.
Please see the illustrations below for explanation when n = 2 and n = 4.

The result might be very large, so you should take module operation with modules 10 9 +7 before print your answer.


 

Input
There are several test cases.
For each test case there is a single line containing only one integer n (1 ≤ n ≤ 1000).
Input is terminated by EOF.


 

Output
For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is the desired answer.


 

Sample Input
  
  
1 2 3 40 50 600 700


 

Sample Output
  
  
Case 1: 1 Case 2: 1 Case 3: 2 Case 4: 924 Case 5: 1998 Case 6: 315478277 Case 7: 825219749


 

Source

 

这一题是今年成都最水的两题之一,复旦的题出的层次感不强,貌似两题出得快就有铜了。

解题思路:采取自底向上的DP,树每长高一次枚举下子树的状态,需要注意的是当输出大于10^9+7时要把结果除以INF取余(一定要注意啊啊啊!!!)

#include<iostream>
#define INF 10000000007
using namespace std;
int main()
{
	int i,j,n;
	long long num=1;
	long long add;
	long long a[2000];
    memset(a,0,sizeof(a));
    a[1]=a[2]=1;
	while(cin>>n)
	{
		for(i=3;i<=n;i++)
	   {add=0;
		   for(j=1;j<i-1;j++)
			   if((i-1)%j==0)
               add+=a[j];
		   a[i]=(a[i-1]+add)%INF;
	   }
		cout<<"Case "<<num<<": "<<a[n]<<endl;
	    num++;
	}
	return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值