POJ 1016 Numbers That Count

Numbers That Count
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17164 Accepted: 5644

Description

"Kronecker's Knumbers" is a little company that manufactures plastic digits for use in signs (theater marquees, gas station price displays, and so on). The owner and sole employee, Klyde Kronecker, keeps track of how many digits of each type he has used by maintaining an inventory book. For instance, if he has just made a sign containing the telephone number "5553141", he'll write down the number "5553141" in one column of his book, and in the next column he'll list how many of each digit he used: two 1s, one 3, one 4, and three 5s. (Digits that don't get used don't appear in the inventory.) He writes the inventory in condensed form, like this: "21131435".

The other day, Klyde filled an order for the number 31123314 and was amazed to discover that the inventory of this number is the same as the number---it has three 1s, one 2, three 3s, and one 4! He calls this an example of a "self-inventorying number", and now he wants to find out which numbers are self-inventorying, or lead to a self-inventorying number through iterated application of the inventorying operation described below. You have been hired to help him in his investigations.

Given any non-negative integer n, its inventory is another integer consisting of a concatenation of integers c1 d1 c2 d2 ... ck dk , where each ci and di is an unsigned integer, every ci is positive, the di satisfy 0<=d1<d2<...<dk<=9, and, for each digit d that appears anywhere in n, d equals di for some i and d occurs exactly ci times in the decimal representation of n. For instance, to compute the inventory of 5553141 we set c1 = 2, d1 = 1, c2 = 1, d2 = 3, etc., giving 21131435. The number 1000000000000 has inventory 12011 ("twelve 0s, one 1").

An integer n is called self-inventorying if n equals its inventory. It is called self-inventorying after j steps (j>=1) if j is the smallest number such that the value of the j-th iterative application of the inventory function is self-inventorying. For instance, 21221314 is self-inventorying after 2 steps, since the inventory of 21221314 is 31321314, the inventory of 31321314 is 31123314, and 31123314 is self-inventorying.

Finally, n enters an inventory loop of length k (k>=2) if k is the smallest number such that for some integer j (j>=0), the value of the j-th iterative application of the inventory function is the same as the value of the (j + k)-th iterative application. For instance, 314213241519 enters an inventory loop of length 2, since the inventory of 314213241519 is 412223241519 and the inventory of 412223241519 is 314213241519, the original number (we have j = 0 in this case).

Write a program that will read a sequence of non-negative integers and, for each input value, state whether it is self-inventorying, self-inventorying after j steps, enters an inventory loop of length k, or has none of these properties after 15 iterative applications of the inventory function.

Input

A sequence of non-negative integers, each having at most 80 digits, followed by the terminating value -1. There are no extra leading zeros.

Output

For each non-negative input value n, output the appropriate choice from among the following messages (where n is the input value, j is a positive integer, and k is a positive integer greater than 1):
n is self-inventorying
n is self-inventorying after j steps
n enters an inventory loop of length k
n can not be classified after 15 iterations

Sample Input

22 
31123314 
314213241519 
21221314 
111222234459 
-1

Sample Output

22 is self-inventorying 
31123314 is self-inventorying 
314213241519 enters an inventory loop of length 2 
21221314 is self-inventorying after 2 steps 
111222234459 enters an inventory loop of length 2 

Source

East Central North America 1998
解题思路:基本上是模拟的水题,注意当某个数字出现次数大于10的时候要在转化成的字符串中将出现次数拆成两个数,我这里WA一次。
#include<iostream>
using namespace std;
int main()
{
	char s[100],temp[100],st[20][100];
	int i,j,k,n,t,min,max,num,len;
	bool flag1,flag2,flag3;
	for(i=0;i<100;i++)
			s[i]='\0';//s数组是当前的转化的数字
	while(cin>>s)
	{
		if(strcmp(s,"-1")==0)
			break;
		for(i=0;i<100;i++)
			temp[i]='\0';
		for(i=0;i<20;i++)
			for(j=0;j<100;j++)
				st[i][j]='\0';
		flag1=flag2=flag3=false;
		strcpy_s(temp,s);
		for(t=0;t<15;t++)
		{
		    len=strlen(s);
			min=10;max=-1;k=0;
		for(i=0;i<len;i++)//找出出现在数字中的最大值和最小值以确定区间
		{
		    if(s[i]-'0'<min)
				min=s[i]-'0';
			if(s[i]-'0'>max)
				max=s[i]-'0';
		}
		strcpy_s(st[t],s);//st数组记录s数组中的的变化值
		for(i=0;i<100;i++)
			s[i]='\0';
		for(i=min;i<=max;i++)
		{   
			num=0;
			for(j=0;j<len;j++)
			{
				if(st[t][j]==i+'0')
					num++;//记录每位数字出现的频率
			}
			if(num==0)//频率为0的数字跳过
				continue;
			if(num<10)//分出现频率大于10和小于10两种情况讨论
		    {s[k++]=num+'0';
			s[k++]=i+'0';}
			else
			{s[k++]=num/10+'0';
			s[k++]=num%10+'0';
			s[k++]=i+'0';}
		}
		for(n=0;n<=t;n++)
		{
			if(strcmp(s,st[n])==0)//15次转化后不满足与之前的任意数字相等,则不构成self-inventorying number
			{
				if(t-n==0&&t==0)//第一次就转化为self-inventorying number
				{
					flag1=true;
					break;
				}
				else if(t-n==0)//经多次转化后成为self-inventorying number
				{
					flag2=true;
					break;
				}
				else//与之前转化的构成循环self-inventorying number
				{
					flag3=true;
					break;
				}
			}
		}
		if(flag1||flag2||flag3)
			break;
		}
		if(flag1)
		    cout<<temp<<" is self-inventorying \n";
		else if(flag2)
			cout<<temp<<" is self-inventorying after "<<t<<" steps \n";
		else if(flag3)
			cout<<temp<<" enters an inventory loop of length "<<t-n+1<<endl;
		else
			cout<<temp<<" can not be classified after 15 iterations \n";
		for(i=0;i<100;i++)
			s[i]='\0';
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值