POJ 1936 All in All

All in All
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 24104 Accepted: 9670

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

Source

Ulm Local 2002
解题思路:直接暴力即可,用两个指针i,j分别指向检验串和母串的对应位置,若对应位置相同则i,j均加1,否则j加1;在上述操作后,若i到达检验串末尾证明检验串中的字母与母串中对应字母的顺序一致,即检验串是母串的字串;若i未到达检验串末尾而j已到达母串末尾证明母串中不存在检验串中的某一字母,或者字母顺序未能按检验串中顺序给出,即检验串不是母串的字串。
#include<iostream>
#include<string>
using namespace std;

int main(long i,long j)
{
	char s1[100000],s2[100000];
	while(cin>>s1>>s2)
	{
		long len1=strlen(s1);
		long len2=strlen(s2);
		i=0;
		j=0;
		while(true)
		{
			if(i==len1)
			{
				cout<<"Yes"<<endl;
				break;
			}
			else if(i<len1 && j==len2)
			{
				cout<<"No"<<endl;
				break;
			}
			if(s1[i]==s2[j])
			{
				i++;
				j++;
			}
			else
				j++;
		}
		memset(s1,'\0',sizeof(s1));
		memset(s2,'\0',sizeof(s2));
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值