杭电1062(Text Reverse)字符串翻转问题

Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26291    Accepted Submission(s): 10214


Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 

Output
For each test case, you should output the text which is processed.
 

Sample Input
  
  
3 olleh !dlrow m'I morf .udh I ekil .mca
 

Sample Output
  
  
hello world! I'm from hdu. I like acm.
Hint
Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.
一开始做这道题的时候想着用string做,把遇到' '之前的内容存到子字符串中,然后再把刚刚的内容在字符串中删掉,最后把这些子字符串整理下。
发现这样来做这道题的话太费时间了,还不如边找边输出快一些。
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int main()
{
	int n,i,j,asd;
	while(cin>>n)
	{
		getchar();
		while(n--)
		{
			string s;
			getline(cin,s);
			j=0;
			asd=0;
			for(i=0;i<s.length();i++){
				if(s[i]==' '){
					for(j=i-1;j>=asd;j--){
						cout<<s[j];
					}
					cout<<" ";
					asd=i+1;
				}
			}
			for(j=i-1;j>=asd;j--)
				cout<<s[j];
			cout<<endl;

		}
	}
	return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值