sicily 1240. Faulty Odometer

1240. Faulty Odometer

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

You are given a car odometer which displays the miles traveled as an integer. The odometer has a defect, however: it proceeds from the digit 3 to the digit 5, always skipping over the digit 4. This defect shows up in all positions (the one's, the ten's, the hundred's, etc.). For example, if the odometer displays 15339 and the car travels one mile, odometer reading changes to 15350 (instead of 15340).

Input

Each line of input contains a positive integer in the range 1..999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is indicated by a line containing a single 0. You may assume that no odometer reading will contain the digit 4.

Output

Each line of input will produce exactly one line of output, which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car.

Sample Input

13
15
2003
2005
239
250
1399
1500
999999
0

Sample Output

13: 12
15: 13
2003: 1461
2005: 1462
239: 197
250: 198
1399: 1052
1500: 1053
999999: 531440

题目分析

十进制计数时少了4,求实际的数
这里要做个转化,
这其实是个9进制数
用符号0表示了数字0
用符号1表示了数字1
用符号2表示了数字2
用符号3表示了数字3
用符号5表示了数字4,用符号6表示了数字5...用符号9表示了数字8
理解了就不难了


#include <stdio.h>

#define scale 9

int change(int digit) {
  int ans = 0;
  int weight = 1;
  while (digit != 0) {
    int temp = digit % 10;
    ans += (temp>4?temp-1:temp) * weight;
    weight *= scale;
    digit = (digit - temp) / 10;
  }
  return ans;
}

int main()
{
  int num;
  while (scanf("%d", &num)) {
    if (num == 0)
      break;
    int ans = change(num);
    printf("%d: %d\n", num, ans);
  }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值