sicily 1009. Mersenne Composite N

1009. Mersenne Composite N

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

One of the world-wide cooperative computing tasks is the "Grand Internet Mersenne Prime Search" -- GIMPS -- striving to find ever-larger prime numbers by examining a particular category of such numbers.
A Mersenne number is defined as a number of the form (2p–1), where p is a prime number -- a number divisible only by one and itself. (A number that can be divided by numbers other than itself and one are called "composite" numbers, and each of these can be uniquely represented by the prime numbers that can be multiplied together to generate the composite number — referred to as its prime factors.)
Initially it looks as though the Mersenne numbers are all primes.

PrimeCorresponding Mersenne Number
24–1 = 3 -- prime
38–1 = 7 -- prime
532–1 = 31 -- prime
7128–1 = 127 -- prime

If, however, we are having a "Grand Internet" search, that must not be the case.
Where k is an input parameter, compute all the Mersenne composite numbers less than 2 k -- where k <= 63 (that is, it will fit in a 64-bit signed integer on the computer). In Java, the "long" data type is a signed 64 bit integer. Under gcc and g++ (C and C++ in the programming contest environment), the "long long" data type is a signed 64 bit integer.

Input

Input is from file a. in. It contains a single number, without leading or trailing blanks, giving the value of k. As promised, k <= 63.

Output

One line per Mersenne composite number giving first the prime factors (in increasing order) separate by asterisks, an equal sign, the Mersenne number itself, an equal sign, and then the explicit statement of the Mersenne number, as shown in the sample output. Use exactly this format. Note that all separating white space fields consist of one blank.

Sample Input

31

Sample Output

23 * 89 = 2047 = ( 2 ^ 11 ) - 1
47 * 178481 = 8388607 = ( 2 ^ 23 ) - 1
233 * 1103 * 2089 = 536870911 = ( 2 ^ 29 ) - 1

题目分析

Mersenne number is a number of the form (2^p–1), where p is a prime number
p 小于64
给定一个数k,求小于(2^k–1)的Mersenne number是否能写成若干个素数相乘
注意题中关于数据类型的说明


#include <iostream>
#include <cmath>

int main()
{
  int key;
  std::cin >> key;
  int prime[] = {2, 3, 5, 7, 11, 13, 17, 19, 23,
                 29, 31, 37, 41, 43, 47, 53, 59}; //key <= 64 && key is prime
  for (int c = 0; prime[c] <= key && c < 17; ++c) {
    long long temp = pow(2.0, prime[c]) - 1;
    long long tempp = temp;
    bool judge = false;
    for (long long d = 3; d <= sqrt(temp); ) { //筛法求素数
      while (temp % d == 0) {
        if (!judge) {
          std::cout << d;
          judge = true;            
        } else {
          std::cout << " * " << d;       
        }
        temp /= d;
      }
      d += 2;   
    }   
    if (judge)
      std::cout << " * " << temp << " = " << tempp 
                << " = ( 2 ^ " << prime[c] << " ) - 1"
                << std::endl;
  }
  return 0;   
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值