sicily 1119. Factstone Benchmark

1119. Factstone Benchmark

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Amtel has announced that it will release a 128-bit computer chip by 2010, a 256-bit computer by 2020, and so on, continuing its strategy of doubling the word-size every ten years. (Amtel released a 64-bit computer in 2000, a 32-bit computer in 1990, a 16-bit computer in 1980, an 8-bit computer in 1970, and a 4-bit computer, its first, in 1960.)

Amtel will use a new benchmark - the Factstone - to advertise the vastly improved capacity of its new chips. The Factstone rating is defined to be the largest integer n such that n! can be represented as an unsigned integer in a computer word.

Input

Given a year 1960 ≤ y ≤ 2160, what will be the Factstone rating of Amtel's most recently released chip?

Output

There are several test cases. For each test case, there is one line of input containing y. A line containing 0 follows the last test case. For each test case, output a line giving the Factstone rating.

Sample Input

1960
1981
0

Sample Output

3
8

题目分析

已知year电脑的位数为bits = pow(2, (year-1960)/10+2)
能表示的最大无符号数为pow(2, bits)
求最大的n使n! <= pow(2, bits)
直接做肯定溢出
将两边取log再做运算


#include <stdio.h>
#include <math.h>

int main()
{
  int year;
  while (scanf("%d", &year) && year) {
    if (year >= 1960 && year <= 2160) {
      double bit = pow(2, (year - 1960) / 10 + 2);
      
      double sum = 0;
      int count = 2;
      while (sum <= bit) {
        sum += log(count) / log(2);
        count++;
      }
      printf("%d\n", count - 2);
    }
  }
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值