sicily 1310. Right-Heavy Tree

1310. Right-Heavy Tree

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

A right-heavy tree is a binary tree where the value of a node is greater than or equal to the values of the nodes in its left subtree and less than the values of the nodes in its right subtree. A right-heavy tree could be empty.

Write a program that will create a right-heavy tree from a given input sequence and then traverse the tree and printing the value of the node each time a node is visited using inorder, preorder and postorder traversal.

The program should create the nodes in the tree dynamically. Thus, basically the tree can be of any size limited only by the amount of memory available in the computer.

Input

The input will contain several test cases, each of them as described below.

The first number in the input indicates the number of nodes in the tree. Then, the input is followed by the integers comprising the values of the nodes of the tree.

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line. The output will be the sequence of node and labeled by the traversal method used, as shown in the sample output below.

Sample Input

8 8 2 4 7 5 3 1 6
9 5 5 6 3 2 9 3 3 2
8 4 2 1 4 3 2 5 1
0

Sample Output

Inorder: 1 2 3 4 5 6 7 8
Preorder: 8 2 1 4 3 7 5 6
Postorder: 1 3 6 5 7 4 2 8

Inorder: 2 2 3 3 3 5 5 6 9
Preorder: 5 5 3 2 2 3 3 6 9
Postorder: 2 3 3 2 3 5 9 6 5

Inorder: 1 1 2 2 3 4 4 5
Preorder: 4 2 1 1 2 4 3 5
Postorder: 1 2 1 3 4 2 5 4

Inorder:
Preorder:
Postorder:

题目分析

构造树,使右节点的值>=根>左节点的值


#include <stdio.h>

struct Node {
  Node *l, *r;
  int id;
  Node () {
  }
  Node (int id_) {
    id = id_;
    l = NULL;
    r = NULL;
  }
};
Node *nodes;

inline void insert(int key) {
  Node *temp;
  temp = nodes;
  while (1) {
    if (temp->id >= key) {
      if (temp->l == NULL) {
        temp->l = new Node(key);
        return;
      } else {
        temp = temp->l;
      } 
    } else {
      if (temp->r == NULL) {
        temp->r = new Node(key);
        return;
      } else {
        temp = temp->r;
      } 
    }
  }
}

inline  void inorder(Node *t) {
  if (t->l != NULL)
    inorder(t->l);
  printf(" %d", t->id);
  if (t->r != NULL)
    inorder(t->r);
}

inline void preorder(Node *t) {
  printf(" %d", t->id);
  if (t->l != NULL)
    preorder(t->l);
  if (t->r != NULL)
    preorder(t->r);
}

inline void postorder(Node *t) {
  if (t->l != NULL)
    postorder(t->l);
  if (t->r != NULL)
    postorder(t->r);
  printf(" %d", t->id);
}

int main() {
  int num;
  bool first = false;
  while (scanf("%d", &num) != EOF) {
    if (first)
      printf("\n");
    first = true;

    if (num == 0) {
      printf("Inorder: \nPreorder: \npostorder: \n");
      break;
    }

    int digit[num];
    for (int c = 0; c < num; ++c)
      scanf("%d", &digit[c]);

    nodes = new Node(digit[0]);
    for (int c = 1; c < num; ++c) {
      insert(digit[c]);
    }

//
    printf("Inorder:");
    inorder(nodes);
    printf("\n");
//
    printf("Preorder:");
    preorder(nodes);
    printf("\n");
//
    printf("Postorder:");
    postorder(nodes);
    printf("\n");
  }
  return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值