POJ_3169_Layout【差分约束】

Description
Like everyone else, cows like to stand close to their friends when queuing for feed.
 FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed.
  The cows are standing in the same order as they are numbered, and since they can be rather pushy,
   it is possible that two or more cows can line up at exactly the same location (that is,
   if we think of each cow as being located at some coordinate on a number line, then it is possible
    for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really
 dislike each other and want to be separated by at least a certain distance. A list of ML
  (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by
  which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which
  cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N
 that satisfies the distance constraints.

Input
Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with
1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D,
with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output
Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily
 far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

题意:编号为1到n的牛排队有些牛是比较友好的需要使他们的相隔的最大距离不能大于某个值还有一些牛需要使他们的最小距离大于某个值求1号牛到n号牛之间能够相隔的最大距离

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#define inf 0x3f3f3f3f
using namespace std;
int dist[1001];
bool used[1001];
int res[1001];
int n,l,d,num;
struct Node 
{
	int u;
	int v;
	int w;
}s[20010];
void add_edge(int x,int y,int z)
{
	s[num].u = x;
	s[num].v = y;
	s[num++].w = z;
}
int Bellman_ford()
{
	memset(dist,inf,sizeof(dist));
	int i,j;
	dist[1] = 0;
	for(i=1;i<n;i++)
	{
		for(j=1;j<=num;j++)
		{
			if(dist[s[j].v]>dist[s[j].u]+s[j].w)
			{
				dist[s[j].v] = dist[s[j].u]+s[j].w;
			}
		}
	}
	for(i=1;i<=num;i++)
	{
		if(dist[s[i].v]>dist[s[i].u]+s[i].w)
		{
			return 0;
		}
	}
	return 1;
}
int main()
{
	while(scanf("%d%d%d",&n,&l,&d)!=EOF)
	{
		int i,j;
		num = 1;
		int a,b,c;
		for(i=1;i<=l;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			add_edge(a,b,c);
		}
		for(i=1;i<=d;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			add_edge(b,a,-c);
		}
		if(!Bellman_ford())
		{
			printf("-1\n");
		}
		else if(dist[n]==inf)
		{
			printf("-2\n");
		}
		else
		{
			printf("%d\n",dist[n]);
		}
	}
	return 0;
}

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int n,m,k;
int head[1050];
int dis[1050];
int vis[1050];
int cout[1050];
int num;
#define INF 0x3f3f3f3f
struct Edge
{
	int u,v,w;
	int next;
}edge[20500];
void add_edge(int x,int y,int z)
{
	edge[num].u=x;
	edge[num].v=y;
	edge[num].w=z;
	edge[num].next=head[x];
	head[x]=num++;
}
int spfa()
{
	int u,i,v,w;
	queue<int> q;
	q.push(1);
	memset(dis,INF,sizeof(dis));
	memset(vis,false,sizeof(vis));
	memset(cout,0,sizeof(cout));
	dis[1]=0;
	vis[1]=true;
	while(!q.empty())
	{
		u=q.front();
		q.pop();
		vis[u]=false;
		cout[u]++;
		if(cout[u]>n)
		{
			return 0;
		}
		for(i=head[u];i!=-1;i=edge[i].next)
		{
			v=edge[i].v;
			w=edge[i].w;
			if(dis[v]>dis[u]+w)
			{
				dis[v]=dis[u]+w;
				if(!vis[v])
				{
					vis[v]=true;
					q.push(v);
				}
			}
		}
	}
	return 1;
}
int main()
{
	while(scanf("%d%d%d",&n,&m,&k)!=EOF)
	{
		int i,j,a,b,c;
		num = 0;
		memset(head,-1,sizeof(head));
		for(i=1;i<=m;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			add_edge(a,b,c);
		}
		for(j=1;j<=k;j++)
		{
            scanf("%d%d%d",&a,&b,&c);
			add_edge(b,a,-c);
		}
       	if(!spfa())
		{
			printf("-1\n");
		}
		else if(dis[n]==INF)
		{
			printf("-2\n");
		}
		else
		{
			printf("%d\n",dis[n]);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值