NYOJ_714_Card Trick【队列】

/*Card Trick
时间限制:1000 ms  |  内存限制:65535 KB
难度:3

描述

    The magician shuffles a small pack of cards, holds it face down and performs the following procedure:

        The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.
        Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.
        Three cards are moved one at a time…
        This goes on until the nth and last card turns out to be the n of Spades.

    This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of the cards for a given number of cards, 1 ≤ n ≤ 13.

输入
    On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10 Each case consists of one line containing the integer n. 1 ≤ n ≤ 13
输出
    For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…
样例输入

    2
    4
    5

样例输出

    2 1 4 3
    3 1 4 5 2

*/   

题意:  抽取上面第一张牌后放到最后,然后现在上面显现的是(梅花)A,然后去掉A,然后再抽取两张放到后面,现在上面的牌显示(梅花) 2 , 然后去掉2  ,依次,,,知道第n次 。。

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
queue<int> Q;
int s[30];
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int n;
		int i,j,k=1;
		int index = 0;
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		{
			Q.push(i);
		}
		for(i=1;i<=n;i++)
		{
			j = i;
			while(j--)//队列 弹出次数 1.2.3...n
			{
				int t = Q.front();
				Q.pop();
				
				Q.push(t);
			}
			index = Q.front();//队首 弹出 index是指 哪个位置 1.2.3...n
			Q.pop();
			s[index] = k++;
		}
		for(i=1;i<=n;i++)
			printf("%d ",s[i]);
		printf("\n");
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
x1y2 x2y3 x3y1-x1y3-x2y1-x3y2 是计算三角形面积的公式中的一部分。 在这个公式中,x1、x2、x3分别表示三角形的三个顶点的x坐标,y1、y2、y3分别表示三角形的三个顶点的y坐标。通过计算这个表达式的值,可以得到三角形的面积。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [TetraCluster:使用并行Java 2库的Java并行程序。 该程序在群集并行计算机上运行,​​以从给定的点集中找到...](https://download.csdn.net/download/weixin_42171208/18283141)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] - *2* [线性代数有个题,求正交变换x=Qy,化二次型f(x1,x2,x3)=8x1x2+8x1x3+8x2x3为标准型求出特征值](https://blog.csdn.net/weixin_39956182/article/details/115882118)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] - *3* [nyoj-67-三角形面积(S=(1/2)*(x1y2+x2y3+x3y1-x1y3-x2y1-x3y2))](https://blog.csdn.net/weixin_30492601/article/details/99541033)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值