nyoj714 Card Trick 队列 河南第6届省赛

Card Trick

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述

The magician shuffles a small pack of cards, holds it face down and performs the following procedure:

  1. The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.
  2. Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.
  3. Three cards are moved one at a time…
  4. This goes on until the nth and last card turns out to be the n of Spades.

This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of the cards for a given number of cards, 1 ≤ n ≤ 13.

输入
On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10 Each case consists of one line containing the integer n. 1 ≤ n ≤ 13
输出
For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…
样例输入
245
样例输出
2 1 4 33 1 4 5 2
来源
第六届河南省程序设计大赛
//抽取上面第一张牌后放到最后,然后现在上面显现的是(梅花)A,然后去掉A,然后再抽取两张放到后面,
//现在上面的牌显示(梅花)2 ,然后去掉2 ,依次,,,直到n次 。。
#include<stdio.h>
#include<cstring>
#include<queue>
using namespace std;
queue<int> Q;
int s[30];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,i,j,k=1;
		int index=0;
		scanf("%d",&n);
		for(i=1;i<=n;i++)//初始化牌 
		Q.push(i);
			
		for(i=1;i<=n;i++)
		{
			j=i;
			while(j--)//队列 弹出次数 1、2、3、...n 第一次弹出来一个第二次弹出来两个 
			{
				int temp=Q.front();
				Q.pop();
				Q.push(temp);
			}
			index=Q.front();//队首 弹出 index指的是位置1、2、3、、、n,不是具体的数字 
			Q.pop();
			s[index]=k++;
		}	
		
		for(i=1;i<=n;i++)
		printf("%d ",s[i]);
		printf("\n");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值