POJ_1159_Palindrome【dp】

/*Palindrome
Time Limit: 3000MS        Memory Limit: 65536K
Total Submissions: 62592        Accepted: 21811

Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2


  题意,给你一个字符串,可在任意位置添加字符,最少再添加几个字符,可以使这个字符串成为回文字符串。
 
  思路:求原串与其逆串的最长公共子序列,然后用串长减去最长公共子序列的长度就是要添加的最少的字符数。
 

*/

#include <cstdio>
#include<iostream>
#include<cstring>
#include <algorithm>
using namespace std;
const int  Max = 5005;
char str1[Max],str2[Max];
int dp[2][Max];
int main()
{
    int n,i,j,k;
    while(cin>>n)
    {
		scanf("%s",&str1[1]);
        for(i=1;i<=n;i++)//str1的逆串
            str2[i]=str1[n-i+1];
        memset(dp,0,sizeof(dp));
        i=0;
        for(k=1;k<=n;k++)
        {   
            i=1-i;//滚动数组
            for(j=1;j<=n;j++)
            {
                if(str1[k]==str2[j]) 
                    dp[i][j] = dp[1-i][j-1] + 1;
                else 
                	dp[i][j] = max(dp[i][j-1], dp[1-i][j]);  
            }
        }
        cout<<n-dp[i][n]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值