蓝桥杯_算法提高_学霸的迷宫(简单回溯法,没有减枝)

问题描述
  学霸抢走了大家的作业,班长为了帮同学们找回作业,决定去找学霸决斗。
但学霸为了不要别人打扰,住在一个城堡里,城堡外面是一个二维的格子迷宫,要进城堡必须得先通过迷宫。
因为班长还有妹子要陪,磨刀不误砍柴功,他为了节约时间,从线人那里搞到了迷宫的地图,准备提前计算最短的路线。
可是他现在正向妹子解释这件事情,于是就委托你帮他找一条最短的路线。
输入格式
  第一行两个整数n, m,为迷宫的长宽。
  接下来n行,每行m个数,数之间没有间隔,为0或1中的一个。0表示这个格子可以通过,1表示不可以。
假设你现在已经在迷宫坐标(1,1)的地方,即左上角,迷宫的出口在(n,m)。
每次移动时只能向上下左右4个方向移动到另外一个可以通过的格子里,每次移动算一步。数据保证(1,1),(n,m)可以通过。
输出格式
  第一行一个数为需要的最少步数K。
  第二行K个字符,每个字符∈{U,D,L,R},分别表示上下左右。如果有多条长度相同的最短路径,选择在此表示方法下字典序最小的一个。
样例输入
Input Sample 1:
3 3
001
100
110

Input Sample 2:
3 3
000
000
000
样例输出
Output Sample 1:
4
RDRD

Output Sample 2:
4
DDRR
数据规模和约定
  有20%的数据满足:1<=n,m<=10
  有50%的数据满足:1<=n,m<=50
  有100%的数据满足:1<=n,m<=500。

import java.util.Scanner;

/**
 * @author 翔
 *
 */
public class Main {
    private static int n;
    private static int m;
    private static char[][] mat;
    private static String minResult;
    private static boolean[][] hasReach; 

    /**
     * @param args
     */
    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner sc=new Scanner(System.in);
        n=sc.nextInt();
        m=sc.nextInt();
        mat=new char[n][m];
        hasReach=new boolean[n][m];
        for(int i=0;i<n;i++){
            mat[i]=sc.next().toCharArray();
        }
        hasReach[0][0]=true;
        fun("",0,0,'U');
        fun("",0,0,'D');
        fun("",0,0,'R');
        fun("",0,0,'L');
//      hasReach[0][0]=false;

        System.out.println(minResult.length());
        System.out.println(minResult);
    }


    private static void fun(String result,int i,int j,char direction){
        if(i==n-1&&j==m-1){
            if(minResult==null||minResult.length()>result.length()||(minResult.length()==result.length()&&minResult.compareTo(result)>0)){
                minResult=result;
            }
            return;
        }

        int nextI=i;
        int nextJ=j;
        switch (direction) {
        case 'U': {
            nextI--;
            if (judge(nextI, nextJ)) {
                hasReach[nextI][nextJ]=true;
                fun(result+'U', nextI, nextJ, 'U');
                fun(result+'U', nextI, nextJ, 'D');
                fun(result+'U', nextI, nextJ, 'R');
                fun(result+'U', nextI, nextJ, 'L');
                hasReach[nextI][nextJ]=false;
            }
            break;
        }
        case 'D': {
            nextI++;
            if (judge(nextI, nextJ)) {
                hasReach[nextI][nextJ]=true;
                fun(result+'D', nextI, nextJ, 'U');
                fun(result+'D', nextI, nextJ, 'D');
                fun(result+'D', nextI, nextJ, 'R');
                fun(result+'D', nextI, nextJ, 'L');
                hasReach[nextI][nextJ]=false;

            }
            break;
        }

        case 'R': {
            nextJ++;
            if (judge(nextI, nextJ)) {
                hasReach[nextI][nextJ]=true;
                fun(result+'R', nextI, nextJ, 'U');
                fun(result+'R', nextI, nextJ, 'D');
                fun(result+'R', nextI, nextJ, 'R');
                fun(result+'R', nextI, nextJ, 'L');
                hasReach[nextI][nextJ]=false;
            }
            break;
        }
        case 'L': {
            nextJ--;
            if (judge(nextI, nextJ)) {
                hasReach[nextI][nextJ]=true;
                fun(result+'L', nextI, nextJ, 'U');
                fun(result+'L', nextI, nextJ, 'D');
                fun(result+'L', nextI, nextJ, 'R');
                fun(result+'L', nextI, nextJ, 'L');
                hasReach[nextI][nextJ]=false;
            }
            break;
        }
        }

    }

    private static boolean judge(int nextI,int nextJ){
        if(nextI==-1||nextI==n||nextJ==-1||nextJ==m){
            return false;
        }else if(hasReach[nextI][nextJ]==true){
            return false;
        }else if(mat[nextI][nextJ]=='1'){
            return false;
        }else{
            return true;
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值