poj 2299

                                                                Ultra-QuickSort

Time Limit: 7000MS
Memory Limit: 65536K
Total Submissions: 55762
Accepted: 20600

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6

0

题意就是求逆序数;

其实这道题本来是要用树状数组来做的,可惜我还不会。我就想到用归并排序来写了。因为在归并排序中,他是将一个数组每次分成一半,直到不能再分。然后每一个小的进行排序,当左边的数组中元素大于右边数组中的元素时就要交换。

#include <iostream>
#include<cstdio>
#include<cstring>
#define maxn 500000+5
using namespace std;
int L[maxn/2],R[maxn/2],A[maxn];
long long cnt;
void merge(int A[],int s,int m,int t)
{
    int nl=m-s+1;
    int nr=t-m;
    for(int i=0;i<nl;i++)
        L[i]=A[i+s];
    for(int j=0;j<nr;j++)
        R[j]=A[j+m+1];
    int x=0,y=0;
    for(int i=s;i<=t;i++){
        if(x<nl&&y<nr){
            if(L[x]>R[y])//有交换时,就进行处理。
            {
                A[i]=R[y++];
                cnt+=nl-x;
            }
            else
                A[i]=L[x++];
        }
        else{
             if(x<nl)
                A[i]=L[x++];
            else
                A[i]=R[y++];
        }
    }
}
void Msort(int A[],int s,int t)
{
    if(s<t)
    {
        int m=(s+t)/2;
        Msort(A,s,m);
        Msort(A,m+1,t);
        merge(A,s,m,t);
    }
}
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        cnt=0;
        for(int i=0;i<n;i++)
            scanf("%d",&A[i]);
        Msort(A,0,n-1);
        printf("%I64d\n",cnt);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值