hdu1326-简单数学题

13 篇文章 0 订阅
12 篇文章 0 订阅
Problem Description
Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you should make all stacks the same height. Then you would have a real wall.'', she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help? 


 

Input
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height. 

The input is terminated by a set starting with n = 0. This set should not be processed. 
 

Output
For each set, first print the number of the set, as shown in the sample output. Then print the line ``The minimum number of moves is k.'', where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height. 

Output a blank line after each set.
 

Sample Input
  
  
6 5 2 4 1 7 5 0
 

Sample Output
  
  
Set #1 The minimum number of moves is 5.
 
题意:问你最少要移动多少个积木,才能使得所以木块一样高。
思路:先排序,只要所以木块不是一样高,最后一个数肯定大于平均数,第一个肯定小于平均数。所以每次只要比较他们两个与平均数的关系就好了。
代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int main()
{
    int a[55],n,cas=1;;
    while(~scanf("%d",&n)&&n)
    {
        int sum=0,x,cnt=0;;
        for(int i=0;i<n;i++){
            scanf("%d",&x);
            a[i]=x;
            sum+=x;
        }
        int sub=sum/n;
        sort(a,a+n);
        printf("Set #%d\n",cas++);
        while(a[n-1]>sub)
        {
            if(a[n-1]-sub>sub-a[0]){//最后一个数与平均高度的差大于平均高度与第一个数的高度差
                cnt+=(sub-a[0]);
                a[n-1]-=(sub-a[0]);//分出一部分高度给第一个数,使得他达到平均高度
                a[0]=sub;
            }
            else if(a[n-1]-sub==sub-a[0]){<span style="font-family: Arial, Helvetica, sans-serif;">//最后一个数与平均高度的差等于平均高度与第一个数的高度差</span>
                cnt+=sub-a[0];
                a[n-1]=a[0]=sub;
            }
            else{<span style="font-family: Arial, Helvetica, sans-serif;">//最后一个数与平均高度的差小于平均高度与第一个数的高度差</span>
                cnt+=a[n-1]-sub;
                a[0]+=a[n-1]-sub;
                a[n-1]=sub;
            }
            sort(a,a+n);
            //printf("%d,%d\n",a[0],a[n-1]);
        }
        printf("The minimum number of moves is %d.\n\n",cnt);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值