HDU 1017 简单数学题

A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26984    Accepted Submission(s): 8587


Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 

Sample Input
  
  
1 10 1 20 3 30 4 0 0
 

Sample Output
  
  
Case 1: 2 Case 2: 4 Case 3: 5
 
简单题:首先N的意思就是有N个组,其中每一组以m=n=0作为结束条件,另外每一组结束都要输出一空格作为结束条件,当N为0 时除外。

代码:
<span style="font-size:18px;">#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <iomanip>

using namespace std;
int main()
{
	int N,n,m,num;
	cin>>N;
	while(N--)
	{
		int flag=1;
		while(cin>>n>>m)
		{
			if(n==0 && m==0)
				break;
			num=0;
			for(int a=1;a<n-1;++a)
			{
				for(int b=a+1;b<n;++b)
				{
					if((a*a+b*b+m)%(a*b)==0)
						num++;
				}
			}
			cout<<"Case "<<flag++<<": "<<num<<endl;
		}
		if(N!=0)
			cout<<endl;

	}
	return 0;
}
</span>



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值