hdu1016-素数环

17 篇文章 0 订阅

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

题意:素数环。要求每一个数与自己前面一个数、后面一个数相加都是素数。

思路:n为奇数时,不可能构成素数环,因为肯定会多出一对奇数互相相加,那肯定是的偶数。

            n为偶数时

                      先构造一张素数表,然后将第一个数定为1,因为题目要求按字典序从小到大。

                     然后进行dfs,我们放数据时,只需要考虑到我们当前要放得这个数与他们前面的数相加是否为素数,最后再判断第一个数与最后一个数相加是否为素数。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
bool isPrim[45],visited[45];
int a[45],n;
void init()
{
    isPrim[0]=isPrim[1]=true;
    for(int i=2; i<sqrt(44); i++)
    {
        for(int j=i*i; j<45; j+=i)
            isPrim[j]=true;
    }
}
void dfs(int k)
{
    if(k==n+1&&!isPrim[a[n]+1])//判断第n个数与第一个数相加是否为素数
    {
        printf("1");
        for(int i=2; i<=n; i++)
        {
            printf(" %d",a[i]);
        }
        printf("\n");
        return;
    }
    else
    {
        for(int i=2; i<=n; i++)//将2~n中的每一个数都去尝试下
        {
            if(!visited[i]&&!isPrim[i+a[k-1]])//如果没有被用过,而且与第k-1个数相加为素数
            {
                a[k]=i;
                visited[i]=true;//标记被访问
                dfs(k+1);
                visited[i]=false;//回溯
            }
        }
    }
}
int main()
{
    int cas=1;
    init();
    while(~scanf("%d",&n))
    {
        memset(visited,false,sizeof(visited));
        printf("Case %d:\n",cas++);
        if(n==1)
            printf("1\n");
        else if((n&1)==0)
        {
            visited[1]=true;
            a[1]=1;
            dfs(2);
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值