D - Red and Black——BFS

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
  1. 1进队 队列是所有元素是1
  2. 1出队 并且在出队前记录他的位置 然后判断他的可行方向 遍历进队
  3. 根据有序的标记 扩散
  4. 不断的删除队首
  5. 最后的队列一定是空的
  6. 然后利用ans记录可以走的黑色瓷砖数

利用STL

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
using namespace std;
const int maxv=100;
int n,m;
char G[maxv][maxv];
bool vis[maxv][maxv]={false};
int x1[4]={0,0,1,-1};
int y1[4]={1,-1,0,0};
struct Node{
	int x,y;
}node;
queue<Node> q;
bool text(int x,int y){//限制条件
	if(y>=n||y<0||x>=m||x<0){
		return false;
	}
	if(G[x][y]=='#'){
		return false;
	}
	if(vis[x][y]==true){
		return false;
	}
	return true;
}
int BFS(int u,int v){
	memset(vis,0,sizeof(vis));
	node.x=u;
	node.y=v;
	q.push(node);
	vis[u][v]=true;
	int ans=1;//记录点的多少
	while(!q.empty()){
		Node top=q.front();
		q.pop();
		for(int i=0;i<4;i++){
			int newx=top.x+x1[i];
			int newy=top.y+y1[i];
			if(text(newx,newy)){
				ans++;
				node.x=newx;
				node.y=newy;
				vis[newx][newy]=true;
				q.push(node);
			}
		}
	}
	return ans;
}
int main(){
	while(scanf("%d%d",&n,&m)!=EOF){
		if(n==0&&m==0){
			break;
		}
		if(!q.empty()){
			q.pop();
		}
		int u=0,v=0;
		for(int i=0;i<m;i++){//制图
			getchar();
			for(int j=0;j<n;j++){
				G[i][j]=getchar();
				if(G[i][j]=='@'){
					u=i;
					v=j;
				}
			}
			G[i][n+1]='\0';
		}
		printf("%d\n",BFS(u,v));
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值