1017 Queueing at Bank (25 point(s)) - C语言 PAT 甲级

1017 Queueing at Bank (25 point(s))

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.
Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤ 104​​) - the total number of customers, and K (≤ 100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.
Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

题目大意:

N 个顾客,K 个窗口,每位顾客有到达时间和业务所需时间,均在黄线外排队,有空窗口就从黄线外进人,求顾客平均等待时间;银行 8:00 工作,17:00 后不接受新业务,每位顾客最多处理时长为 1 小时

设计思路:

相当于每个窗口只容纳一人,只需为每个窗口维护一个结束时间

  1. 读取数据,根据到达时间排序
  2. 遍历 17:00 之前到达的顾客,查询完成时间最早的窗口,则:
    • 顾客到达时间早于此窗口结束时间:两者之差累加到等待时间,此窗口结束时间累加顾客业务时间
    • 顾客到达时间晚于此窗口结束时间:顾客无等待时间,此窗口结束时间更新为顾客到达时间加业务时间
编译器:C (gcc)
#include <stdio.h>

struct customer {
        int start;
        int time;
};

int cmp(const void *a, const void *b)
{
        struct customer *c1 = (struct customer *)a;
        struct customer *c2 = (struct customer *)b;
        return c1->start - c2->start;
}

int main(void)
{
        int n, k;
        int hh, mm, ss;
        int wait = 0, endtime[100] = {0};
        struct customer customers[10000], *p;
        int i, j;

        scanf("%d %d", &n, &k);
        for (i = 0; i < n; i++) {
                scanf("%d:%d:%d %d", &hh, &mm, &ss, &customers[i].time);
                customers[i].start = ((hh - 8) * 60 + mm ) * 60 + ss;
                customers[i].time *= 60;
        }

        qsort(customers, n, sizeof(struct customer), cmp);

        for (i = 0; (customers[i].start <= (17 - 8) * 3600) && (i < n); i++) {
                p = customers + i;

                int num = 0;
                for (j = 0; j < k; j++)
                        if (endtime[j] < endtime[num])
                                num = j;

                if (p->time > 3600)
                        p->time = 3600;


                if(p->start < endtime[num]) {
                        wait += endtime[num] - p->start;
                        endtime[num] += p->time;
                } else {
                        endtime[num] = p->start + p->time;
                }
        }

        if (i)
                printf("%.1f", wait / 60.0 / i);
        else
                printf("0.0");

        return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值