1058 A+B in Hogwarts (20point(s))
If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon
is an integer in [0, 107], Sickle
is an integer in [0, 17), and Knut
is an integer in [0, 29)).
Input Specification:
Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input.
Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28
题目大意:
29 个 Knut 换一个 Sickle,17 个 Sickle 换一个 Galleon,加法运算输入的两组数据
设计思路:
- 加法的进位运算
- 另一种思路,把所有的数换成 Knut,再按照规则输出
编译器:C (gcc)
#include <stdio.h>
int main(void) {
int a, b, c, d, e, f;
scanf("%d.%d.%d %d.%d.%d", &a, &b, &c, &d, &e, &f);
c = c + f;
b = b + e + c / 29;
a = a + d + b / 17;
printf("%d.%d.%d", a, b % 17, c % 29);
return 0;
}