1068 Find More Coins (30point(s)) - C语言 PAT 甲级

1068 Find More Coins (30point(s))

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 10​4​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤104, the total number of coins) and M (≤102, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V1≤V2≤⋯≤Vk such that V1≤V2≤⋯≤Vk=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output “No Solution” instead.

Note: sequence {A[1], A[2], …} is said to be “smaller” than sequence {B[1], B[2], …} if there exists k≥1 such that A[i]=B[i] for all i<k, and A[k] < B[k].

Sample Input 1:

8 9
5 9 8 7 2 3 4 1

Sample Output 1:

1 3 5

Sample Input 2:

4 8
7 2 4 3

Sample Output 2:

No Solution

题目大意:

输入 N 个硬币,要求选择若干硬币恰好等于支付金额 M,选择的硬币越小越好

设计思路:

0-1 背包问题生动讲解
递归+枚举的方法

  • 需要输出序列较小的答案,先对硬币排序从大到小,
  • 然后按照 0-1 背包问题求解,即先选大面额的硬币,后续遇到小面额符合条件的就选择小面额
  • 除了背包问题所需的 dp[] 递推数组,还需要额外建立 choice[][] 数组表示硬币选择情况
编译器:C (gcc)
#include <stdio.h>

int cmp(const void *a, const void *b)
{
        return *((int *)b) - *((int *)a);
}

int main(void)
{
        int n, m;
        int dp[10010] = {0}, v[10010] = {0}, select[10010][110] = {0};
        int i, j;

        scanf("%d%d", &n, &m);
        for (i = 1; i <= n; i++)
                scanf("%d", &v[i]);
        qsort(v + 1, n, sizeof(v[0]), cmp);
        for (i = 1; i <= n; i++) {
                for (j = m; j >= v[i]; j--) {
                        if (dp[j] <= dp[j - v[i]] + v[i]) {
                                select[i][j] = 1;
                                dp[j] = dp[j - v[i]] + v[i];
                        }
                }
        }
        if (dp[m] != m) {
                printf("No Solution");
        } else {
                int f = 0;
                i = n;
                j = m;
                while (j > 0) {
                        if (select[i][j] == 1) {
                                printf("%s%d", f ? " " : "", v[i]);
                                f = 1;
                                j -= v[i];
                        }
                        i--;
                }
        }
        return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值