1101 Quick Sort (25point(s)) - C语言 PAT 甲级

1101 Quick Sort (25point(s))

1101 Quick Sort (25point(s))

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤105). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

题目大意:

1045 快速排序 (25point(s))

设计思路:

1045 快速排序(C语言)
主要是降低时间复杂度

  1. 以主元的定义,暴力判断,时间复杂度 O(N*N)
  2. 利用数组记录每个数前面的最大值,后面的最小值,时间复杂度 O(N)

最初解题时很简单的想到,在输入时记录每个数前面的最大值,然后就想怎么记录每个数后面的最小值,因为数据是从前往后读取,记录最小值的方法越想越乱,最后看到大佬的代码才反应过来,数据都存好了,从后往前再读一次就是最小值(囧,想撞死在键盘上~~)

编译器:C (gcc)
#include <stdio.h>

int main()
{
    int n, count = 0;
    int num[100000], lmax[100000], rmin[100000];
    int i, max, min;

    scanf("%d", &n);
    for(i = 0, max = i; i < n; i++){
        scanf("%d", num + i);
        lmax[i] = num[i] >= num[max] ? num[max = i] : num[max];
    }
    for(i = n - 1, min = i; i >= 0; i--){
        rmin[i] = num[i] <= num[min] ? num[min = i] : num[min];
    }
    for(i = 0; i < n; i++){
        if(num[i] == lmax[i] && num[i] == rmin[i]){
            count++;
        }
        else{
            num[i] = 0;
        }
    }
    printf("%d\n", count);
    for(i = 0; i < n && count; i++){
        if(num[i]){
            printf("%d%c", num[i], --count ? ' ' : '\0');
        }
    }
    printf("\n");

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值