1104 Sum of Number Segments (20point(s))
Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).
Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 105. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.
Output Specification:
For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.
Sample Input:
4
0.1 0.2 0.3 0.4
Sample Output:
5.00
Thanks to Ruihan Zheng for correcting the test data.
题目大意:
设计思路:
- 方法一利用双重循环加和
- 方法二是直接根据数字的位置,计算这个数字被重复加了几次,
设数字个数为 n,数字位于第 i 位,则:
重复次数 = i * (n - i)
和乙级相比,这道题因为 Ruihan Zheng,https://blog.zhengrh.com/post/about-double/ 大佬的反馈,计算结果需要更高的精度,把浮点数转换成 long long 长整型计算
编译器:C (gcc)
#include <stdio.h>
int main(void)
{
int n;
double num;
long long sum = 0;
int i;
scanf("%d", &n);
for (i = 0; i < n; i++) {
scanf("%lf", &num);
sum += ((long long)(num * 1000)) * (i + 1) * (n - i);
}
printf("%.2lf\n", sum / 1000.0);
return 0;
}
/*
#include <stdio.h>
int main()
{
int n;
double num, sum = 0.0;
int i;
scanf("%d", &n);
for(i = 0; i < n; i++){
scanf("%lf", &num);
sum += num * (i + 1) * (n - i);
}
printf("%.2lf\n", sum);
return 0;
}
*/