1136 A Delayed Palindrome (20point(s))
Consider a positive integer N written in standard notation with k+1 digits ai as ak⋯a1a0 with 0≤ai<10 for all i and ak>0. Then N is palindromic if and only if ai=ak−i for all i. Zero is written 0 and is also palindromic by definition.
Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )
Given any positive integer, you are supposed to find its paired palindromic number.
Input Specification:
Each input file contains one test case which gives a positive integer no more than 1000 digits.
Output Specification:
For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:
A + B = C
where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number – in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.
Sample Input:
97152
Sample Output:
97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.
Sample Input:
196
Sample Output:
196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.
题目大意:
设计思路:
- 此题难点在于大数的相加。思路是让数组存数字时,个位数在数组低位 a[0] 上,此时两数相加可直接进位,省去进位移动数组的麻烦
- 读取初始值时特殊处理一次即可
- 利用自定义函数逆转数组,输出数组即可
编译器:C (gcc)
#include <stdio.h>
#include <string.h>
int reverse_ab(char a[], char b[]);
int add_ab(char a[], char b[]);
int is_palindrome(char a[]);
int print_ab(char a[], char b[]);
int print_str(char a[]);
int main()
{
char a[1011] = {0}, b[1011] = {0};
int i = 0;
scanf("%s", b);
if (!is_palindrome(b)) {
reverse_ab(b, a);
print_ab(a, b);
for (i = 1; i < 10 && !is_palindrome(a); i++) {
reverse_ab(a, b);
print_ab(a, b);
}
}
if (i == 10) {
printf("Not found in 10 iterations.");
} else {
i > 0 ? print_str(a) : print_str(b);
printf(" is a palindromic number.");
}
return 0;
}
int reverse_ab(char a[], char b[])
{
int len = strlen(a);
int i;
for (i = 0; i < len; i++)
b[len - i - 1] = a[i];
return 0;
}
int add_ab(char a[], char b[])
{
int len = strlen(a);
int i, sum, carry = 0;
for (i = 0; i < len; i++) {
sum = a[i] - '0' + b[i] - '0' + carry;
a[i] = sum % 10 + '0';
carry = sum / 10;
}
if (carry)
a[i] = carry + '0';
return 0;
}
int is_palindrome(char a[])
{
int len = strlen(a);
int i;
for (i = 0; i < len / 2; i++)
if (a[i] != a[len - i - 1])
return 0;
return 1;
}
int print_ab(char a[], char b[])
{
print_str(a);
printf(" + ");
print_str(b);
printf(" = ");
add_ab(a, b);
print_str(a);
printf("\n");
return 0;
}
int print_str(char a[])
{
int i = strlen(a) - 1;
for (; i >= 0; i--)
printf("%c", a[i]);
return 0;
}