1141 PAT Ranking of Institutions (25point(s)) - C语言 PAT 甲级

1141 PAT Ranking of Institutions (25point(s))

After each PAT, the PAT Center will announce the ranking of institutions based on their students’ performances. Now you are asked to generate the ranklist.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format:

ID Score School

where ID is a string of 6 characters with the first one representing the test level: B stands for the basic level, A the advanced level and T the top level; Score is an integer in [0, 100]; and School is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that ID is unique for each testee.

Output Specification:

For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:

Rank School TWS Ns

where Rank is the rank (start from 1) of the institution; School is the institution code (all in lower case); ; TWS is the total weighted score which is defined to be the integer part of ScoreB/1.5 + ScoreA + ScoreT*1.5, where ScoreX is the total score of the testees belong to this institution on level X; and Ns is the total number of testees who belong to this institution.

The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in alphabetical order of their codes.

Sample Input:

10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu

Sample Output:

5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2

题目大意:

1085 PAT单位排行 (25point(s))

设计思路:

1085 PAT单位排行(C语言)

  • 从题目上也可看出,又是一道排序题
编译器:C (gcc)
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct student{
        char id[7], school[7];
        int score;
};

struct school{
        char name[7];
        int score;
        int num;
};

int cmp_school(const void *a, const void *b)
{
        return strcmp(((struct student*)a)->school, ((struct student*)b)->school);
}

int cmp_score(const void *a, const void *b)
{
        struct school *s1 = (struct school*)a, *s2 = (struct school*)b;
        if (s1->score - s2->score)
                return s2->score - s1->score;
        else if (s1->num - s2->num)
                return s1->num - s2->num;
        else
                return strcmp(s1->name, s2->name);
}

int main()
{
        struct student stus[100001] = {0};
        struct school schs[100001] = {0};
        int n, m = 0, num = 0;
        double sum = 0;
        int i, j;
        char *tmp;

        scanf("%d", &n);
        for (i = 0; i < n; i++) {
                scanf("%s %d %s", stus[i].id, &stus[i].score, stus[i].school);
                for (tmp = stus[i].school; *tmp; tmp++)
                        *tmp = tolower(*tmp);
        }

        qsort(stus, n, sizeof(stus[0]), cmp_school);

        for (i = 0; i < n; i++) {
                switch (stus[i].id[0]) {
                case 'B':
                        sum += stus[i].score / 1.5;
                        break;
                case 'A':
                        sum += stus[i].score;
                        break;
                case 'T':
                        sum += stus[i].score * 1.5;
                        break;
                }
                num++;
                if (i == n - 1 || strcmp(stus[i].school, stus[i + 1].school)) {
                        strcpy(schs[m].name, stus[i].school);
                        schs[m].score = (int)sum;
                        schs[m].num = num;
                        sum = 0;
                        num = 0;
                        m++;
                }
        }

        qsort(schs, m, sizeof(schs[0]), cmp_score);

        printf("%d\n", m);
        for (i = 0, j = 0; i < m; i++) {
                if (i > 0 && schs[i].score < schs[i - 1].score)
                        j = i;
                printf("%d %s %d %d\n", j + 1, schs[i].name,
                                schs[i].score, schs[i].num);
        }

        return 0;
}
深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值