1143 Lowest Common Ancestor (30point(s)) - C语言 PAT 甲级

1143 Lowest Common Ancestor (30point(s))

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.
The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found…

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

题目大意:

输入 M 次查询,N 个节点的二叉搜索树,并给出树的先序序列,每次查询给出两个节点

输出查询节点的最低公共祖先

设计思路:
  • 先遍历一遍看看所给节点是否在二叉树中
  • 最低公共节点表示,两节点一定分别在最低公共节点左子树和右子树中
  • 因为是二叉搜索树,所以两节点是否在某节点的左右子树,可以用节点值的大小判断
编译器:C (gcc)
#include <stdio.h>

int main(void)
{
        int n, m, pre[10010];
        int u, v, i, j;
        int iu, iv;

        scanf("%d%d", &m, &n);
        for (i = 0; i < n; i++)
                scanf("%d", &pre[i]);
        for (i = 0; i < m; i++) {
                scanf("%d%d", &u, &v);
                iu = n;
                iv = n;
                for (j = 0; j < n; j++) {
                        if (pre[j] == u)
                                iu = j;
                        if (pre[j] == v)
                                iv = j;
                }
                if (iu == n && iv == n) {
                        printf("ERROR: %d and %d are not found.\n", u, v);
                } else if (iu == n) {
                        printf("ERROR: %d is not found.\n", u);
                } else if (iv == n) {
                        printf("ERROR: %d is not found.\n", v);
                } else {
                        for (j = 0; j < n; j++)
                                if ((pre[j] >= u && pre[j] <= v) || (pre[j] >= v && pre[j] <= u))
                                        break;
                        if (pre[j] == u)
                                printf("%d is an ancestor of %d.\n", u, v);
                        else if (pre[j] == v)
                                printf("%d is an ancestor of %d.\n", v, u);
                        else
                                printf("LCA of %d and %d is %d.\n", u, v, pre[j]);
                }
        }
        return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值