1145 Hashing - Average Search Time (25point(s)) - C语言 PAT 甲级

1145 Hashing - Average Search Time (25point(s))

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 104. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 105​​.

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

题目大意:

输入 Msize,代表哈希表的大小,在哈希表中用平方探测法插入 N 个数,若无法插入则输出此数 cannot be inserted,接着查询 M 个数在哈希表中的位置,输出 m 个数查找的平均时间

设计思路:
  • 先更新 Msize 为第一个大于等于其本身的素数,表示真正的哈希表大小
  • 平方探测法插入 N 个数据
  • 查询 M 个数据的时间,就是指查找长度

注意:

  • 查询时,j <= msize,正常来说 (a + 0 * 0) % msize 等价于 (a + msize * msize) % msize,所以不需要加等号
  • 但本题需要有等于号,是因为不加 PAT 后台过不了
编译器:C (gcc)
#include <stdio.h>

int isprime(int n)
{
        int i;
        if (n <= 1)
                return 0;
        for (i = 2; i * i <= n; i++)
                if (n % i == 0)
                        return 0;
        return 1;
}

int main(void)
{
        int hash[10007] = {0};
        int msize, n, m;
        int i, j, a, pos;

        scanf("%d%d%d", &msize, &n, &m);
        while (!isprime(msize))
                msize++;
        for (i = 0; i < n; i++) {
                scanf("%d", &a);
                for (j = 0; j <= msize; j++) {
                        pos = (a + j * j) % msize;
                        if (hash[pos] == 0) {
                                hash[pos] = a;
                                break;
                        }
                }
                if (j >= msize)
                        printf("%d cannot be inserted.\n", a);
        }
        int sum = 0;
        for (i = 0; i < m; i++) {
                scanf("%d", &a);
                for (j = 0; j <= msize; j++) {
                        sum++;
                        pos = (a + j * j) % msize;
                        if (hash[pos] == a || hash[pos] == 0)
                                break;
                }
        }
        printf("%.1lf\n", sum * 1.0 / m);
        return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值