1146 Topological Order (25point(s)) - C语言 PAT 甲级

1146 Topological Order (25point(s))

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
figure

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

题目大意:

输入 N 个节点,M 条有向边的有向图,查询 K 个序列,判断所给序列是否为拓扑排序

输出不是拓扑排序的序列号

设计思路:
  • 保存每个节点的入度
  • 当到达某节点时,将此节点能到达的节点入度减 1
  • 遍历所给序列节点时,有入度不为 0 的节点,说明不是拓扑排序
编译器:C (gcc)
#include <stdio.h>

int graph[1010][1010] = {0}, cnt[1010] = {0};

int main(void)
{
        int n, m, k;
        int degree[1010] = {0};
        int i, j, a, b;

        scanf("%d %d", &n, &m);
        for (i = 0; i < m; i++) {
                scanf("%d%d", &a, &b);
                graph[a][cnt[a]] = b;
                cnt[a]++;
                degree[b]++;
        }
        int t, space = 0, temp[1010];
        scanf("%d", &k);
        for (i = 0; i < k; i++) {
                for (j = 1; j <= n; j++)
                        temp[j] = degree[j];
                for (j = 0; j < n; j++) {
                        scanf("%d", &a);
                        if (temp[a] != 0) {
                                printf("%s%d", space == 1 ? " ": "", i);
                                space = 1;
                                for (j++; j < n; j++)
                                        scanf("%d", &a);
                                break;
                        }
                        for (t = 0; t < cnt[a]; t++)
                                temp[graph[a][t]]--;
                }
        }

        return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值