1148 Werewolf - Simple Version (20point(s)) - C语言 PAT 甲级

1148 Werewolf - Simple Version (20point(s))

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

player #1 said: "Player #2 is a werewolf.";
player #2 said: "Player #3 is a human.";
player #3 said: "Player #4 is a werewolf.";
player #4 said: "Player #5 is a human."; and
player #5 said: "Player #4 is a human.".

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence – that is, for two sequences A=a[1],…,a[M] and B=b[1],…,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input:
5
-2
+3
-4
+5
+4
Sample Output:

1 4

Sample Input:
6
+6
+3
+1
-5
-2
+4
Sample Output:

1 5

Sample Input:
5
-2
-3
-4
-5
-1
Sample Output:

No Solution

题目大意:

1089 狼人杀-简单版 (20point(s))

设计思路:

1089 狼人杀-简单版(C语言)

  • 又是初看题目毫无头绪的题
  1. 数组 v[101] 记录每个人说的话
  2. 数组 a[101] 记录每次假设的实际身份,-1 为狼人,0 为好人
  3. 每次假设后遍历一次每个人说的话,若和假设的身份冲突,说明此人说谎,添加至 lie[101]
  4. 数组 lie[101] 最终有一个狼人和一个好人,则符合题目,否则,从第 2 步继续假设
编译器:C (gcc)
#include <stdio.h>
#include <stdlib.h>

int main()
{
        int n, v[101];
        int a[101], lie[101];
        int i, j, k, l, count;

        scanf("%d", &n);
        for (i = 1; i <= n; i++)
                scanf("%d", v + i);

        for (i = 1; i <= n; i++) {
                for (j = i + 1; j <= n; j++) {
                        for (l = 1; l <= n; l++)
                                a[l] = 1;
                        a[i] = -1;
                        a[j] = -1;
                        count = 0;
                        for (k = 1; k <= n; k++)
                                if (v[k] * a[abs(v[k])] < 0)
                                        lie[count++] = k;
                        if (count == 2 && a[lie[0]] + a[lie[1]] == 0) {
                                printf("%d %d", i, j);
                                return 0;
                        }
                }
        }
        printf("No Solution");

        return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值