欧拉回路-Door Man

Door Man
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 2476 Accepted: 1001

Description
You are a butler in a large mansion. This mansion has so many rooms that they are merely referred to by number (room 0, 1, 2, 3, etc…). Your master is a particularly absent-minded lout and continually leaves doors open throughout a particular floor of the house. Over the years, you have mastered the art of traveling in a single path through the sloppy rooms and closing the doors behind you. Your biggest problem is determining whether it is possible to find a path through the sloppy rooms where you:

Always shut open doors behind you immediately after passing through
Never open a closed door
End up in your chambers (room 0) with all doors closed

In this problem, you are given a list of rooms and open doors between them (along with a starting room). It is not needed to determine a route, only if one is possible.

Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.
A single data set has 3 components:

Start line - A single line, "START M N", where M indicates the butler's starting room, and N indicates the number of rooms in the house (1 <= N <= 20).
Room list - A series of N lines. Each line lists, for a single room, every open door that leads to a room of higher number. For example, if room 3 had open doors to rooms 1, 5, and 7, the line for room 3 would read "5 7". The first line in the list represents room 0. The second line represents room 1, and so on until the last line, which represents room (N - 1). It is possible for lines to be empty (in particular, the last line will always be empty since it is the highest numbered room). On each line, the adjacent rooms are always listed in ascending order. It is possible for rooms to be connected by multiple doors!
End line - A single line, "END"

Following the final data set will be a single line, “ENDOFINPUT”.

Note that there will be no more than 100 doors in any single data set.

Output
For each data set, there will be exactly one line of output. If it is possible for the butler (by following the rules in the introduction) to walk into his chambers and close the final open door behind him, print a line “YES X”, where X is the number of doors he closed. Otherwise, print “NO”.

Sample Input

START 1 2
1

END
START 0 5
1 2 2 3 3 4 4

END
START 0 10
1 9
2
3
4
5
6
7
8
9

END
ENDOFINPUT

Sample Output

YES 1
NO
YES 10

Source
South Central USA 2002
题意:给你起点m和房间的个数n,接下来有n行,第一行代表房间0与之相连的房间编号(只列出比它大的房间编号,按升序),一个房间可能有多个门,问可从起点出发将所有的门关上,并回到房间0,如果可以关上输出”YES X”,X代表关上的门的数量,不能输出”NO”.
方法:一道无向图的欧拉回路的题,判断是不是欧拉回路,就看图的度,如果度为奇数的个数为零,则无论从哪一个点出发都可以回到0,如果度为奇数的为2个,则这两个点一个为起点一个为终点,需要判断起点是不是度为奇数并且0的度也为零,(m!=0).其余的情况都不可以.这个题的数据处理比较麻烦点.

#include <map>
#include <list>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
#define eps 1e-9
#define LL long long
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define CRR fclose(stdin)
#define CWW fclose(stdout)
#define RR freopen("input.txt","r",stdin)
#pragma comment(linker, "/STACK:102400000")
#define WW freopen("output.txt","w",stdout)

const int MAX = 11000;

char buf[MAX];
char s[50];
int Du[120];

int ReadLine()
{
    int L;
    for(L=0;(buf[L]=getchar())!='\n'&&buf[L]!=EOF;L++);
    buf[L]='\0';
    return L;
}
int  main()
{
    int n,m;
    int door;
    while(ReadLine())
    {
        if(buf[0]=='S')
        {
            sscanf(buf,"%s %d %d",s,&m,&n);
            memset(Du,0,sizeof(Du));
            door=0;
            for(int i=0;i<n;i++)
            {
                ReadLine();
                int k=0;
                int v;
                while(sscanf(buf+k,"%d",&v)==1)
                {
                    door++;
                    Du[i]++;
                    Du[v]++;
                    while(buf[k]&&buf[k++]==' ');
                    while(buf[k]&&buf[k++]!=' ');
                }
            }
            ReadLine();
            int ood=0;
            for(int i=0;i<n;i++)
            {
                if(Du[i]&1)
                {
                    ood++;
                }
            }
            if((ood==0&&m==0)||(ood==2&&Du[m]&1&&Du[0]&1&&m))
            {
                printf("YES %d\n",door);
            }
            else
            {
                printf("NO\n");
            }
        }
        else if(!strcmp(buf,"ENDOFINPUT"))
        {
            break;
        }
    }
    return 0;
}
1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看rEADME.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看rEADME.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值