欧拉回路

欧拉回路

昨天讲了欧拉回路,做了一道题,今天根据这道题写一下我对欧拉回路的一些理解。

定义

通过图中所有边一次且仅一次行遍所有顶点的通路称为欧拉通路。

通过图中所有边一次且仅一次行遍所有顶点的回路称为欧拉回路。

具有欧拉回路的图称为欧拉图。

具有欧拉通路的图称为半欧拉图。

有向图的时候可以类似地定义。

性质

欧拉图中所有顶点的度数都是偶数。

若 G是欧拉图,则它若干个边不重的圈的并。

判别方法

G是欧拉图当且仅当G是连通的且没有奇度定点。

G是半欧拉图当且仅当G中恰有两个奇度定点。

附一道例题来展现一下代码如何实现判断欧拉回路

Door Man(POJ 1300)

Description

You are a butler in a large mansion. This mansion has so many rooms that they are merely referred to by number (room 0, 1, 2, 3, etc…). Your master is a particularly absent-minded lout and continually leaves doors open throughout a particular floor of the house. Over the years, you have mastered the art of traveling in a single path through the sloppy rooms and closing the doors behind you. Your biggest problem is determining whether it is possible to find a path through the sloppy rooms where you:
Always shut open doors behind you immediately after passing through
Never open a closed door
End up in your chambers (room 0) with all doors closed
In this problem, you are given a list of rooms and open doors between them (along with a starting room). It is not needed to determine a route, only if one is possible.

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.
A single data set has 3 components:
Start line - A single line, “START M N”, where M indicates the butler’s starting room, and N indicates the number of rooms in the house (1 <= N <= 20).
Room list - A series of N lines. Each line lists, for a single room, every open door that leads to a room of higher number. For example, if room 3 had open doors to rooms 1, 5, and 7, the line for room 3 would read “5 7”. The first line in the list represents room 0. The second line represents room 1, and so on until the last line, which represents room (N - 1). It is possible for lines to be empty (in particular, the last line will always be empty since it is the highest numbered room). On each line, the adjacent rooms are always listed in ascending order. It is possible for rooms to be connected by multiple doors!
End line - A single line, “END”
Following the final data set will be a single line, “ENDOFINPUT”.
Note that there will be no more than 100 doors in any single data set.

Output

For each data set, there will be exactly one line of output. If it is possible for the butler (by following the rules in the introduction) to walk into his chambers and close the final open door behind him, print a line “YES X”, where X is the number of doors he closed. Otherwise, print “NO”.

Sample Input

START 1 2
1
END
START 0 5
1 2 2 3 3 4 4
END
START 0 10
1 9
2
3
4
5
6
7
8
9
END
ENDOFINPUT

Sample Output

YES 1
NO
YES 10

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<map>
#include<queue>
#define mem(a) memset(a,0,sizeof(a))
#define min(a,b) (a<b?a:b)
#define max(a,b) (a>b?a:b)
using namespace std;
typedef long long ll;
const long long MAXn=1e6+5;
const int inf=0x3f3f3f3f;
int in[205];
int main()
{
    int i,j,a,b,p,k,n,m,door;
    char s[205],s1[205];
    while(scanf("%s",&s))
    {
        mem(in);
        if(s[0]=='E')
            break;
        scanf("%d %d",&n,&m);
        getchar();
        door=0;
        for(i=0;i<m;i++)
        {
            j=0;
            mem(s1);
            gets(s1);
            while(s1[j]!=NULL&&s1[j]!=' ')
            {
                if(s1[j+1]<'0'||s1[j+1]>'9')
                {
                    door++;
                    in[i]++;
                    in[s1[j]-48]++;
                    j+=2;
                }
                else if(s1[j+1]>='0'&&s1[j+1]<='9')
                {
                    door++;
                    p=(s1[j]-48)*10+(s1[j+1]-48);
                    in[i]++;
                    in[p]++;
                    j+=3;
                }
            }
        }
        gets(s);
        int flag1 = 0, flag2 = 0;
        for(i = 0; i < m; i++)     //判断一个顶点的度是否为偶数
        {
            if(in[i] % 2==0)
            {
                flag1++;
            }
            else
            {
                flag2++;
            }
        }
        if(flag2==0&&n==0)
			printf("YES %d\n",door);
        else if(flag2==2 && in[n]%2!=0 && in[0]%2!=0 && n!=0)
            printf("YES %d\n",door);
        else
            printf("NO\n");
    }
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值