Network Saboteur

Network Saboteur
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10147 Accepted: 4849

Description
A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts.
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks.
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him.
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input
The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000).
Output file must contain a single integer – the maximum traffic between the subnetworks.

Output
Output must contain a single integer – the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

Source
Northeastern Europe 2002, Far-Eastern Subregion
刚开始看的时候以为是Dp或者是图论,后来查看题解突然明白自己还是没有理解什么是dfs,dfs就是一种暴力,对于这个题中的每一个点都有两个选择,和0一个集合还是不是一个集合,至于sum为什么能记录两个集合之间的距离,自己画个图就会明白

#include <map>
#include <list>
#include <climits>
#include <cmath>
#include <queue>
#include <stack>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
#define eps 1e-9
#define LL unsigned long long
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define CRR fclose(stdin)
#define CWW fclose(stdout)
#define RR freopen("input.txt","r",stdin)
#define WW freopen("output.txt","w",stdout)

const int Max = 10010;

int Map[25][25];

bool vis[25];

int n;

int MM;

void DFS(int s,int sum)
{
    vis[s]=true;
    for(int i=0;i<n;i++)
    {
        if(vis[i])//如果是同一个集合,之间的距离会为0;
        {
            sum-=Map[s][i];
        }
        else
        {
            sum+=Map[s][i];
        }
    }
    MM = max(MM,sum);//找最大值
    for(int i=s+1;i<n;i++)
    {
        vis[i]=true;
        DFS(i,sum);
        vis[i]=false;
    }
}

int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                scanf("%d",&Map[i][j]);
            }
        }
        MM=0;
        DFS(0,0);
        printf("%d\n",MM);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值