【HDU3949】XOR——线性基

44 篇文章 2 订阅
9 篇文章 0 订阅
Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)

Problem Description

XOR is a kind of bit operator, we define that as follow: for two binary base number A and B, let C=A XOR B, then for each bit of C, we can get its value by check the digit of corresponding position in A and B. And for each digit, 1 XOR 1 = 0, 1 XOR 0 = 1, 0 XOR 1 = 1, 0 XOR 0 = 0. And we simply write this operator as ^, like 3 ^ 1 = 2,4 ^ 3 = 7. XOR is an amazing operator and this is a question about XOR. We can choose several numbers and do XOR operatorion to them one by one, then we get another number. For example, if we choose 2,3 and 4, we can get 2^3^4=5. Now, you are given N numbers, and you can choose some of them(even a single number) to do XOR on them, and you can get many different numbers. Now I want you tell me which number is the K-th smallest number among them.

Input

First line of the input is a single integer T(T<=30), indicates there are T test cases.
For each test case, the first line is an integer N(1<=N<=10000), the number of numbers below. The second line contains N integers (each number is between 1 and 10^18). The third line is a number Q(1<=Q<=10000), the number of queries. The fourth line contains Q numbers(each number is between 1 and 10^18) K1,K2,……KQ.

Output

For each test case,first output Case #C: in a single line,C means the number of the test case which is from 1 to T. Then for each query, you should output a single line contains the Ki-th smallest number in them, if there are less than Ki different numbers, output -1.

Sample Input

2
2
1 2
4
1 2 3 4
3
1 2 3
5
1 2 3 4 5

Sample Output

Case #1:
1
2
3
-1
Case #2:
0
1
2
3
-1

Hint

If you choose a single number, the result you get is the number you choose.
Using long long instead of int because of the result may exceed 2^31-1.

线性基裸题.线性基好像2014集训队论文有

#include <bits/stdc++.h>

using namespace std;

typedef long long LL;
const int maxn = 11000;

LL a[maxn];

int main() {
    int T,z = 1;
    scanf("%d",&T);
    while(T--) {
        int n;
        scanf("%d",&n);
        for(int i = 0;i<n;i++) {
            scanf("%lld",&a[i]);
        }
        int row  = 0;
        bool flag = false;
        for(int i = 62;i>=0&&row<n;i--) {
            int r  = row;
            for(int j = row+1;j<n;j++) {
                if((a[j]>>i)&1) r = j;
            }
            if((a[r]>>i)&1) {
                swap(a[row],a[r]);
                for(int j = 0;j<n;j++) {
                    if(j!=row && ((a[j]>>i)&1)) {
                        a[j] = a[j]^a[row];
                        if(!a[j]) flag = true;
                    }
                }
                row++;
            }
        }
        int q;
        LL k;
        scanf("%d",&q);
        LL ans ;
        printf("Case #%d:\n",z++);
        for(int i = 1;i<=q;i++) {
            scanf("%lld",&k);
            if(flag) k--;
            if(k>>row) {
                printf("-1\n");
                continue;
            }
            ans = 0;
            for(int j = 0;j<row;j++) {
                if((k>>j)&1) {
                    ans^=a[row-1-j];
                }
            }
            printf("%lld\n",ans);
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值