D - 容斥poj1142【数学方法】

点击打开链接


Smith Numbers
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13810 Accepted: 4701

Description

While skimming his phone directory in 1982, Albert Wilansky, a mathematician of Lehigh University,noticed that the telephone number of his brother-in-law H. Smith had the following peculiar property: The sum of the digits of that number was equal to the sum of the digits of the prime factors of that number. Got it? Smith's telephone number was 493-7775. This number can be written as the product of its prime factors in the following way: 
4937775= 3*5*5*65837

The sum of all digits of the telephone number is 4+9+3+7+7+7+5= 42,and the sum of the digits of its prime factors is equally 3+5+5+6+5+8+3+7=42. Wilansky was so amazed by his discovery that he named this kind of numbers after his brother-in-law: Smith numbers. 
As this observation is also true for every prime number, Wilansky decided later that a (simple and unsophisticated) prime number is not worth being a Smith number, so he excluded them from the definition. 
Wilansky published an article about Smith numbers in the Two Year College Mathematics Journal and was able to present a whole collection of different Smith numbers: For example, 9985 is a Smith number and so is 6036. However,Wilansky was not able to find a Smith number that was larger than the telephone number of his brother-in-law. It is your task to find Smith numbers that are larger than 4937775!

Input

The input file consists of a sequence of positive integers, one integer per line. Each integer will have at most 8 digits. The input is terminated by a line containing the number 0.

Output

For every number n > 0 in the input, you are to compute the smallest Smith number which is larger than n,and print it on a line by itself. You can assume that such a number exists.

Sample Input

4937774
0

Sample Output

4937775


给你一个数N,求满足条件的大于N 的最小的那个数,条件是其各位数字的和等于其分解质因数后质因数各位数字的和。


题解:用到了分治算法。。。。




#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
bool IsPrime(int t){
	int k=sqrt(t+0.1);//注意:t要加个小数,sqrt()里边的参数是实型的,不然POJ编译通不过,本人亲测 
	for(int i=2;i<=k;i++){
		if(t%i==0){
			return false;
		}
	}
	return true;
}
int s(int t){
	int i,w=0;
	while(t!=0){
		i=t%10;
		w+=i;
		t/=10;
	}
	return w;
}
int two(int t){
	if(IsPrime(t)){
		return s(t);
	}
	for(int i=(int)sqrt(t+0.1);i>1;i--){
		if(t%i==0){
			return two(i)+two(t/i);//分治;求各个因数的s 
		}
	}
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF&&n){
	while(n++){
		if(!IsPrime(n)&&s(n)==two(n))
			break;
	}	
	printf("%d\n",n);
	}
	return 0;
}











评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值