【G - A Simple Problem with Integers 树状数组 】

点击打开链接


  
  

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000. The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000. Each of the next Q lines represents an operation. "C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000. "Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
Hint
The sums may exceed the range of 32-bit integers.



  
  

#include<cstdio>
#include<cstring>
#define NUM 100005
typedef long long LL;
LL C[2][NUM],n,m;
LL summ[NUM];
LL Lowbit(int x)
{
	return x&-x;
} 
void Plus(LL C[],LL pos,LL num)
{
	while(pos<=n)
	{
		C[pos]+=num;
		pos+=Lowbit(pos);
	}
}
LL Sum(LL C[],LL end)
{
	LL sum=0;
	while(end>0)
	{
		sum+=C[end];
		end-=Lowbit(end);
	}
	return sum;
}
int main()
{
	LL cas,Q,l,r,tem,change;
	while(~scanf("%lld%lld",&cas,&Q))
	{
			memset(C,0,sizeof(C));
			n=cas;
			for(int i=1;i<=n;i++)
				scanf("%lld",&summ[i]);
			summ[0]=0;
			for(int i=1;i<=n;i++)
				summ[i] += summ[i-1];
			char str[3];
			for(int i=1;i<=Q;i++)
			{
				scanf("%s",str);
				if(strcmp(str,"C")==0)
				{
					scanf("%lld%lld%lld",&l,&r,&change);
					Plus(C[0],l,change);
					Plus(C[1],l,l*change);
					Plus(C[0],r+1,-change);
					Plus(C[1],r+1,-change*(r+1));
				}
				else {
					scanf("%lld%lld",&l,&r);
					LL summary=(Sum(C[0],r)*(r+1)-Sum(C[1],r))-(Sum(C[0],l-1)*l-Sum(C[1],l-1));
					summary+=summ[r]-summ[l-1];
					printf("%lld\n",summary);
				}
			}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值