基础架构系列篇-系统centos7安装docker+COMPOSE

1. 环境

查看系统内核版本>=3.10
在这里插入图片描述
删除版本
yum remove docker
docker-client
docker-client-latest
docker-common
docker-latest
docker-latest-logrotate
docker-logrotate
docker-engine
docker-selinux
container-selinux

更新yum源包
yum update

更新索引
yum makecache fast

安装引用包
yum install -y yum-utils device-mapper-persistent-data lvm2

设置yum源
yum-config-manager --add-repo https://download.docker.com/linux/centos/docker-ce.repo

查看版本
yum list docker-ce --showduplicates | sort -r

2. 安装docker

yum install docker-ce

有异常
–> Finished Dependency Resolution
Error: Package: containerd.io-1.4.3-3.1.el7.x86_64 (docker-ce-stable)
Requires: container-selinux >= 2:2.74
Error: Package: docker-ce-rootless-extras-20.10.3-3.el7.x86_64 (docker-ce-stable)
Requires: slirp4netns >= 0.4
Error: Package: docker-ce-rootless-extras-20.10.3-3.el7.x86_64 (docker-ce-stable)
Requires: fuse-overlayfs >= 0.7
Error: Package: 3:docker-ce-20.10.3-3.el7.x86_64 (docker-ce-stable)
Requires: container-selinux >= 2:2.74
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

使用RPM安装
wget http://mirror.centos.org/centos/7/extras/x86_64/Packages/container-selinux-2.119.2-1.911c772.el7_8.noarch.rpm

rpm -ivh container-selinux-2.119.2-1.911c772.el7_8.noarch.rpm

选择降版本
在这里插入图片描述
yum install docker-ce-19.03.8 docker-ce-cli-19.03.8 containerd.io
(安装指定版本:yum install docker-ce-版本号 docker-ce-cli-版本号 containerd.io)

启动docker
systemctl start docker

开机启动
systemctl enable docker

停止docker
systemctl stop docker

验证
docker version 或 docker -v或docker info
在这里插入图片描述

3. 安装docker-compose(使用pip方式)

yum -y install python-pip
yum -y install epel-release
pip --version
pip install --upgrade “pip < 21.0”
pip install docker-compose
异常
Cannot uninstall ‘requests’.
pip install docker-compose --ignore-installed requests
docker-compose version

相关推荐
©️2020 CSDN 皮肤主题: 数字20 设计师:CSDN官方博客 返回首页