setuptools,pip,install,UnicodeDecodeError: 'ascii' codec can't decode byte.原因和解决方案

昨天重装Python2.7.6时,为了安装第三方库,我去下 pip。为了装pip,又得先装  ez_setup.py。结果装ez_setup时,遇到了问题,报错:

UnicodeDecodeError: 'ascii' codec can't decode byte 0xb0 in position 1: ordinal not in range(128)
Something went wrong during the installation.
See the error message above.

网上找了一大圈,发现也有人在bitbucket提了相同的问题,同时这个stackoverflow的问题也与之类似。

现在发现,这应该都是同一个问题。原因与注册表有关,可能与某些国产软件对注册表的改写的gbk格式导致python无法进行第三方库的安装操作。

解决方法:打开C:\Python27\Lib下的 mimetypes.py 文件,找到大概256行(你可以用Notepad++的搜索功能)的

‘default_encoding = sys.getdefaultencoding()’。

在这行前面添加三行:

if sys.getdefaultencoding() != 'gbk':
	reload(sys)
	sys.setdefaultencoding('gbk')
default_encoding = sys.getdefaultencoding()



保存,就解决问题了。


=========UPDATE 2015/03/03============

很久没登录CSDN博客,惊奇发现有这么多朋友特意 注册/登录 来道谢。真的很开心我帮到你们了。文章阅读量也快1万了,估计大部分人都是python初学者甚至是编程初学者吧,我自学python时也是从无数前人的博文、stackoverflow问答中学习的,希望你们也能继承开源社区优秀的奉献精神~~


                

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:大白 设计师:CSDN官方博客 返回首页
评论 35

打赏作者

hugleecool

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值